summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-05 10:23:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-15 14:25:29 +0300
commita0d2ecde943bd1854ddbb7c0cad35a1fc64dc5ab (patch)
tree77f44035ebf5d7b3bffeb4de935f6af2782fa3ae /gnu/packages/patches
parentef026e68fe58ed3be216c76f7c5f008893ed3095 (diff)
gnu: tootle: Deprecate in favor of tuba.
* gnu/packages/mastodon.scm (tootle): Deprecate for tuba. * gnu/packages/patches/tootle-glib-object-renaming.patch, gnu/packages/patches/tootle-reason-phrase.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/tootle-glib-object-naming.patch66
-rw-r--r--gnu/packages/patches/tootle-reason-phrase.patch48
2 files changed, 0 insertions, 114 deletions
diff --git a/gnu/packages/patches/tootle-glib-object-naming.patch b/gnu/packages/patches/tootle-glib-object-naming.patch
deleted file mode 100644
index 08ee23dd8f..0000000000
--- a/gnu/packages/patches/tootle-glib-object-naming.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From 0816105028c26965e37c9afc7c598854f3fecde1 Mon Sep 17 00:00:00 2001
-From: Clayton Craft <clayton@craftyguy.net>
-Date: Tue, 26 Oct 2021 15:03:25 -0700
-Subject: [PATCH] Adhere to GLib.Object naming conventions for properties
-
-Vala now validates property names against GLib.Object conventions, this
-fixes a compilation error as a result of this enforcement:
-
-../src/API/Status.vala:27.5-27.23: error: Name `_url' is not valid for a GLib.Object property
- public string? _url { get; set; }
- ^^^^^^^^^^^^^^^^^^^
-
-Relevant Vala change:
-https://gitlab.gnome.org/GNOME/vala/-/commit/38d61fbff037687ea4772e6df85c7e22a74b335e
-
-fixes #337
-
-Signed-off-by: Clayton Craft <clayton@craftyguy.net>
----
- src/API/Attachment.vala | 6 +++---
- src/API/Status.vala | 8 ++++----
- 2 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/src/API/Attachment.vala b/src/API/Attachment.vala
-index 88bc5bb..35c4018 100644
---- a/src/API/Attachment.vala
-+++ b/src/API/Attachment.vala
-@@ -4,10 +4,10 @@ public class Tootle.API.Attachment : Entity, Widgetizable {
- public string kind { get; set; default = "unknown"; }
- public string url { get; set; }
- public string? description { get; set; }
-- public string? _preview_url { get; set; }
-+ private string? t_preview_url { get; set; }
- public string? preview_url {
-- set { this._preview_url = value; }
-- get { return (this._preview_url == null || this._preview_url == "") ? url : _preview_url; }
-+ set { this.t_preview_url = value; }
-+ get { return (this.t_preview_url == null || this.t_preview_url == "") ? url : t_preview_url; }
- }
-
- public File? source_file { get; set; }
-diff --git a/src/API/Status.vala b/src/API/Status.vala
-index 4f92cdb..00e8a9f 100644
---- a/src/API/Status.vala
-+++ b/src/API/Status.vala
-@@ -28,16 +28,16 @@ public class Tootle.API.Status : Entity, Widgetizable {
- public ArrayList<API.Mention>? mentions { get; set; default = null; }
- public ArrayList<API.Attachment>? media_attachments { get; set; default = null; }
-
-- public string? _url { get; set; }
-+ private string? t_url { get; set; }
- public string url {
- owned get { return this.get_modified_url (); }
-- set { this._url = value; }
-+ set { this.t_url = value; }
- }
- string get_modified_url () {
-- if (this._url == null) {
-+ if (this.t_url == null) {
- return this.uri.replace ("/activity", "");
- }
-- return this._url;
-+ return this.t_url;
- }
-
- public Status formal {
diff --git a/gnu/packages/patches/tootle-reason-phrase.patch b/gnu/packages/patches/tootle-reason-phrase.patch
deleted file mode 100644
index 72a1d1ecfa..0000000000
--- a/gnu/packages/patches/tootle-reason-phrase.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 858ee78fbebe161a4cdd707a469dc0f045211a51 Mon Sep 17 00:00:00 2001
-From: Max Harmathy <harmathy@mailbox.org>
-Date: Wed, 25 Aug 2021 13:05:58 +0200
-Subject: [PATCH] Use reason_phrase instead of get_phrase
-
----
- src/Services/Cache.vala | 2 +-
- src/Services/Network.vala | 7 +------
- 2 files changed, 2 insertions(+), 7 deletions(-)
-
-diff --git a/src/Services/Cache.vala b/src/Services/Cache.vala
-index 2251697..2ed314e 100644
---- a/src/Services/Cache.vala
-+++ b/src/Services/Cache.vala
-@@ -88,7 +88,7 @@ public class Tootle.Cache : GLib.Object {
- try {
- var code = msg.status_code;
- if (code != Soup.Status.OK) {
-- var error = network.describe_error (code);
-+ var error = msg.reason_phrase;
- throw new Oopsie.INSTANCE (@"Server returned $error");
- }
-
-diff --git a/src/Services/Network.vala b/src/Services/Network.vala
-index fa2839c..d0143b0 100644
---- a/src/Services/Network.vala
-+++ b/src/Services/Network.vala
-@@ -56,7 +56,7 @@ public class Tootle.Network : GLib.Object {
- else if (status == Soup.Status.CANCELLED)
- debug ("Message is cancelled. Ignoring callback invocation.");
- else
-- ecb ((int32) status, describe_error ((int32) status));
-+ ecb ((int32) status, msg.reason_phrase);
- });
- }
- catch (Error e) {
-@@ -65,11 +65,6 @@ public class Tootle.Network : GLib.Object {
- }
- }
-
-- public string describe_error (uint code) {
-- var reason = Soup.Status.get_phrase (code);
-- return @"$code: $reason";
-- }
--
- public void on_error (int32 code, string message) {
- warning (message);
- app.toast (message);