summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-09-24 01:39:00 -0400
committerMathieu Othacehe <othacehe@gnu.org>2022-09-30 15:43:35 +0200
commita47a051e3d8669c51071f224661e0f7a9c5a9aaa (patch)
tree3e1df89dd6a5cf0357ff745b9019e85695d116ba /gnu/packages/patches
parent0f66ef9aa99d2043abccbc80d858bdeca57534ac (diff)
gnu: picard: Update to 2.8.3, modernize package.
* gnu/packages/music.scm (picard): Update to 2.8.3. [source]: Remove patch. [arguments]: Use G-expressions. Remove trailing #t. [native-inputs]: Remove input labels. [inputs]: Add python-fasteners, python-pyyaml, python-markdown, python-pyjwt. Remove a transitive dependency on QtWebKit. See <https://issues.guix.gnu.org/53289> for more information about this change. * gnu/packages/patches/picard-fix-id3-rename-test.patch: Remove it. * gnu/local.mk (dist_path_DATA): Update accordingly. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/picard-fix-id3-rename-test.patch11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/patches/picard-fix-id3-rename-test.patch b/gnu/packages/patches/picard-fix-id3-rename-test.patch
deleted file mode 100644
index 3c4fa63c84..0000000000
--- a/gnu/packages/patches/picard-fix-id3-rename-test.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Index: b/test/formats/test_id3.py
-===================================================================
---- a/test/formats/test_id3.py
-+++ b/test/formats/test_id3.py
-@@ -266,5 +266,5 @@
- def test_rename_txxx_tags(self):
- file_path = os.path.join('test', 'data', 'test-id3-rename-tags.mp3')
-- filename = self.copy_file_tmp(file_path, 'mp3')
-+ filename = self.copy_file_tmp(file_path, '.mp3')
- raw_metadata = load_raw(filename)
- self.assertIn('TXXX:Artists', raw_metadata)