summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-09-03 13:15:30 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-09-03 13:24:34 +0200
commitbd3d71cb16de546b534be7a3d03880922f6a1c07 (patch)
tree9356e64e7819198b1d78fd0e97acd323955b4f44 /gnu/packages/patches
parent0481289cbccba2646bf654f0ae49ac9c45602d5d (diff)
gnu: hdf4: Build with libtirpc.
* gnu/packages/patches/hdf4-tirpc.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/maths.scm (hdf4)[source](patches): Use it. [inputs]: Add LIBTIRPC. [arguments]: Adjust #:configure-flags accordingly.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/hdf4-tirpc.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/hdf4-tirpc.patch b/gnu/packages/patches/hdf4-tirpc.patch
new file mode 100644
index 0000000000..3f436e3887
--- /dev/null
+++ b/gnu/packages/patches/hdf4-tirpc.patch
@@ -0,0 +1,33 @@
+Build with libtirpc on all architectures because glibc no longer provides
+SunRPC support.
+
+diff --git a/configure b/configure
+--- a/configure
++++ b/configure
+@@ -23635,10 +23635,13 @@
+ *-pc-cygwin*)
+ LIBS="$LIBS -ltirpc"
+ CPPFLAGS="$CPPFLAGS -I/usr/include/tirpc" ;;
++ *-linux-gnu)
++ LIBS="$LIBS -ltirpc"
++ CPPFLAGS="$CPPFLAGS" ;;
+ *) ;;
+ esac
+
+-if test "X$BUILD_XDR" != "Xyes"; then
++if test "X$BUILD_XDR" = "Xyes"; then
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -23693,9 +23696,9 @@
+ ## but we need to make sure that it is present on the system. Do that here,
+ ## The SunRPC of the glibc has been replaced by a TI-RPC (Transport Independent RPC) library for IPv6 support
+ case "$host" in
+- *-pc-cygwin*)
++ *)
+ HAVE_RPC="yes"
+- ac_fn_c_check_header_mongrel "$LINENO" "rpc.h" "ac_cv_header_rpc_h" "$ac_includes_default"
++ ac_fn_c_check_header_mongrel "$LINENO" "rpc/rpc.h" "ac_cv_header_rpc_h" "$ac_includes_default"
+ if test "x$ac_cv_header_rpc_h" = xyes; then :
+ :
+ else