summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-17 23:25:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-19 03:40:09 -0400
commitd891d7897001d1dbfe4ec93c6f72fc4f51fb0627 (patch)
treee4131e4819a6ed22b3f18fe4b7dc810166625a3f /gnu/packages/patches
parent2c4572448ec4879be89e6fc37be45cc22b566ed1 (diff)
gnu: qemu: Update to 8.2.2.
* gnu/packages/virtualization.scm (qemu): Update to 8.2.2. [source]: Adjust snippet. [arguments] <phases>: Patch tests sources with native /bin/sh. Also patch /bin/sh references in migration/migration.c, util/envlist.c files. * gnu/packages/patches/qemu-disable-some-qtests-tests.patch: Delete file. * gnu/packages/patches/qemu-disable-bios-tables-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Update accordingly. Change-Id: Ia44017e4d567ede1995ae707ed6acbb1ec5194fe
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/qemu-disable-bios-tables-test.patch (renamed from gnu/packages/patches/qemu-disable-some-qtests-tests.patch)36
1 files changed, 12 insertions, 24 deletions
diff --git a/gnu/packages/patches/qemu-disable-some-qtests-tests.patch b/gnu/packages/patches/qemu-disable-bios-tables-test.patch
index f60698de8f..39b7b0b53c 100644
--- a/gnu/packages/patches/qemu-disable-some-qtests-tests.patch
+++ b/gnu/packages/patches/qemu-disable-bios-tables-test.patch
@@ -1,20 +1,18 @@
-Disable the qtest-aarch64/migration-test, which sometimes fail
-non-deterministically (see:
-https://gitlab.com/qemu-project/qemu/-/issues/1230).
+The bios-tables-test may fail; disable it (see: https://gitlab.com/qemu-project/qemu/-/issues/1098)
-Also disable the bios-tables-test, which may fail on older machines (see:
-https://gitlab.com/qemu-project/qemu/-/issues/1098).
-
---- qemu-8.1.0/tests/qtest/meson.build.old 2023-08-30 11:48:27.871146249 -0400
-+++ qemu-8.1.0/tests/qtest/meson.build 2023-08-30 13:53:25.994084948 -0400
-@@ -1,6 +1,5 @@
+diff --git a/tests/qtest/meson.build b/tests/qtest/meson.build
+index f096cf3ecd..82f6e1ffeb 100644
+--- a/tests/qtest/meson.build
++++ b/tests/qtest/meson.build
+@@ -1,7 +1,6 @@
slow_qtests = {
'ahci-test' : 60,
+ 'aspeed_smc-test': 360,
- 'bios-tables-test' : 120,
'boot-serial-test' : 60,
'migration-test' : 150,
'npcm7xx_pwm-test': 150,
-@@ -81,9 +80,6 @@
+@@ -82,9 +81,6 @@ qtests_i386 = \
config_all_devices.has_key('CONFIG_Q35') and \
config_all_devices.has_key('CONFIG_VIRTIO_PCI') and \
slirp.found() ? ['virtio-net-failover'] : []) + \
@@ -24,27 +22,17 @@ https://gitlab.com/qemu-project/qemu/-/issues/1098).
qtests_pci + \
qtests_cxl + \
['fdc-test',
-@@ -212,7 +208,6 @@
-
+@@ -213,7 +209,6 @@ qtests_arm = \
+
# TODO: once aarch64 TCG is fixed on ARM 32 bit host, make bios-tables-test unconditional
qtests_aarch64 = \
- (cpu != 'arm' and unpack_edk2_blobs ? ['bios-tables-test'] : []) + \
(config_all.has_key('CONFIG_TCG') and config_all_devices.has_key('CONFIG_TPM_TIS_SYSBUS') ? \
['tpm-tis-device-test', 'tpm-tis-device-swtpm-test'] : []) + \
(config_all_devices.has_key('CONFIG_XLNX_ZYNQMP_ARM') ? ['xlnx-can-test', 'fuzz-xlnx-dp-test'] : []) + \
-@@ -222,8 +217,7 @@
- config_all_devices.has_key('CONFIG_TPM_TIS_I2C') ? ['tpm-tis-i2c-test'] : []) + \
- ['arm-cpu-features',
- 'numa-test',
-- 'boot-serial-test',
-- 'migration-test']
-+ 'boot-serial-test']
-
- qtests_s390x = \
- qtests_filter + \
-@@ -301,7 +295,6 @@
+@@ -304,7 +299,6 @@ if gnutls.found()
endif
-
+
qtests = {
- 'bios-tables-test': [io, 'boot-sector.c', 'acpi-utils.c', 'tpm-emu.c'],
'cdrom-test': files('boot-sector.c'),