summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2023-09-16 11:06:07 +0200
committerChristopher Baines <mail@cbaines.net>2023-09-25 11:30:02 +0100
commitd953a1e5d678be58887704df6f10cb19a8fd48bf (patch)
tree275cda5079cb57cd98e6a6d3b32640c1887c885b /gnu/packages/patches
parent3fef73ed03ff51e5fc9c17f58a3797872a2150d1 (diff)
gnu: kiwix-desktop: Update to 2.3.1.
* gnu/packages/web.scm (kiwix-desktop): Update to 2.3.1. * gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch b/gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch
new file mode 100644
index 0000000000..a5bee60ac2
--- /dev/null
+++ b/gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch
@@ -0,0 +1,40 @@
+Description: Fix building kiwix-desktop with libkiwix-12.1.0
+Bug: https://github.com/kiwix/kiwix-desktop/issues/964
+Origin: https://github.com/kiwix/kiwix-desktop/commit/1b322d8f01c787846546a6473f153cf1daa41e65
+Applied-Upstream: https://github.com/kiwix/kiwix-desktop/commit/1b322d8f01c787846546a6473f153cf1daa41e65
+---
+From 1b322d8f01c787846546a6473f153cf1daa41e65 Mon Sep 17 00:00:00 2001
+From: Matthieu Gautier <mgautier@kymeria.fr>
+Date: Thu, 9 Feb 2023 09:47:47 +0100
+Subject: [PATCH] With last version of libkiwix, Downloader now return
+ shared_ptr<Download>.
+
+---
+ src/contentmanager.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/contentmanager.cpp b/src/contentmanager.cpp
+index c2f4ff9..d4db50a 100644
+--- a/src/contentmanager.cpp
++++ b/src/contentmanager.cpp
+@@ -173,7 +173,7 @@ QStringList ContentManager::updateDownloadInfos(QString id, const QStringList &k
+ return values;
+ }
+ auto& b = mp_library->getBookById(id);
+- kiwix::Download* d;
++ std::shared_ptr<kiwix::Download> d;
+ try {
+ d = mp_downloader->getDownload(b.getDownloadId());
+ } catch(...) {
+@@ -270,7 +270,7 @@ QString ContentManager::downloadBook(const QString &id)
+ for (auto b : booksList)
+ if (b.toStdString() == book.getId())
+ return "";
+- kiwix::Download *download;
++ std::shared_ptr<kiwix::Download> download;
+ try {
+ std::pair<std::string, std::string> downloadDir("dir", downloadPath.toStdString());
+ const std::vector<std::pair<std::string, std::string>> options = { downloadDir };
+--
+2.41.0
+