summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-07 11:09:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-07 11:09:42 +0100
commite8f4ce74280f035c2224875602bb06e3b59ed746 (patch)
treeda7fa46701926fddc13c8bc87eea89dc3a727655 /gnu/packages/patches
parentfb3dfff677e5610897fd0154d764aa9ec208c2e3 (diff)
gnu: azr3: Update to 1.2.3-1.3391a0a.
* gnu/packages/audio.scm (azr3): Update to 1.2.3-1.3391a0a. [arguments]: Replace bootstrap phase. * gnu/packages/patches/azr3-remove-lash.patch, gnu/packages/patches/azr3.patch: Update patches.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/azr3-remove-lash.patch2
-rw-r--r--gnu/packages/patches/azr3.patch12
2 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/patches/azr3-remove-lash.patch b/gnu/packages/patches/azr3-remove-lash.patch
index d62bd1e93c..d5d481c5dd 100644
--- a/gnu/packages/patches/azr3-remove-lash.patch
+++ b/gnu/packages/patches/azr3-remove-lash.patch
@@ -19,7 +19,7 @@ index 7c9f4f0..f82ba75 100644
textbox.hpp textbox.cpp
azr3_SOURCEDIR = azr3
-azr3_CFLAGS = `pkg-config --cflags gtkmm-2.4 jack lash-1.0` -DDATADIR=\"$(pkgdatadir)\"
--azr3_LDFLAGS = `pkg-config --libs gtkmm-2.4 jack lash-1.0`
+-azr3_LDFLAGS = `pkg-config --libs gtkmm-2.4 jack lash-1.0` -lpthread
+azr3_CFLAGS = `pkg-config --cflags gtkmm-2.4 jack` -DDATADIR=\"$(pkgdatadir)\"
+azr3_LDFLAGS = `pkg-config --libs gtkmm-2.4 jack` -lpthread
azr3_cpp_CFLAGS = $(shell if pkg-config --atleast-version=0.107 jack ; then echo -include azr3/newjack.hpp; fi)
diff --git a/gnu/packages/patches/azr3.patch b/gnu/packages/patches/azr3.patch
index 5849383c5b..93e9b5b11a 100644
--- a/gnu/packages/patches/azr3.patch
+++ b/gnu/packages/patches/azr3.patch
@@ -68,9 +68,9 @@ The patch has been sent to the developer on 2016-09-26.
Widget* eb = add_clickbox(m_fbox, 14, 319, 14, 44);
eb->signal_button_press_event().
- connect(sigc::hide(bind(bind(mem_fun(*this, &AZR3GUI::change_mode),
-- ref(m_fbox)), false)));
+- sigc::ref(m_fbox)), false)));
+ connect(sigc::hide(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::change_mode),
-+ false, std::ref(m_fbox))));
++ false, sigc::ref(m_fbox))));
m_fx_widgets.push_back(eb);
// Mr Valve controls
@@ -79,15 +79,15 @@ The patch has been sent to the developer on 2016-09-26.
Widget* eb2 = add_clickbox(m_vbox, 14, 53, 14, 44);
eb2->signal_button_press_event().
- connect(sigc::hide(bind(bind(mem_fun(*this, &AZR3GUI::change_mode),
-- ref(m_fbox)), true)));
+- sigc::ref(m_fbox)), true)));
+ connect(sigc::hide(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::change_mode),
-+ true, std::ref(m_fbox))));
++ true, sigc::ref(m_fbox))));
// vibrato controls
add_switch(m_vbox, n_1_vibrato, 39, 17, Switch::Green);
@@ -352,9 +352,9 @@
knob->set_style(s);
- if (port >= 0 && port < m_adj.size()) {
+ if (port < m_adj.size()) {
knob->get_adjustment().signal_value_changed().
- connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed), port),
- mem_fun(knob->get_adjustment(),
@@ -100,7 +100,7 @@ The patch has been sent to the developer on 2016-09-26.
}
@@ -382,8 +382,8 @@
db->set_style(s);
- if (port >= 0 && port < m_adj.size()) {
+ if (port < m_adj.size()) {
db->get_adjustment().signal_value_changed().
- connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed), port),
- mem_fun(db->get_adjustment(), &Adjustment::get_value)));