summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-10-12 10:02:25 -0400
committerLudovic Courtès <ludo@gnu.org>2023-10-21 00:27:26 +0200
commitfed6ac2ae182597a492b17a29ed8b26986498755 (patch)
tree085d6d159f779bd4d3143add0ad9358512c7adef /gnu/packages/patches
parentc942f4dcaba8f44d9f89540c22825e935c5acfd1 (diff)
gnu: trilinos-for-dealii-openmpi: Fix build.
This fixes the error error: ‘std::hypot’ has not been declared caused by using an older version of gcc, but requires some patches to placate newer versions of gcc. * gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[origin]: Add patches. [native-inputs]: Remove gcc-7. * gnu/packages/patches/teuchos-remove-duplicate-using.patch: New file. * gnu/packages/patches/tpetra-remove-duplicate-using.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/teuchos-remove-duplicate-using.patch34
-rw-r--r--gnu/packages/patches/tpetra-remove-duplicate-using.patch18
2 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/patches/teuchos-remove-duplicate-using.patch b/gnu/packages/patches/teuchos-remove-duplicate-using.patch
new file mode 100644
index 0000000000..55cd3f6fc3
--- /dev/null
+++ b/gnu/packages/patches/teuchos-remove-duplicate-using.patch
@@ -0,0 +1,34 @@
+commit e27d9ae98502626d8407045a4e082797682ba56b
+Author: Christian Glusa <caglusa@sandia.gov>
+Date: Fri Jul 3 18:02:27 2020 -0600
+
+ Teuchos Comm test: remove duplicate 'using ...'
+
+diff --git a/packages/teuchos/comm/test/Comm/reduce.cpp b/packages/teuchos/comm/test/Comm/reduce.cpp
+index c05ebc0dc34..eac1975ef83 100644
+--- a/packages/teuchos/comm/test/Comm/reduce.cpp
++++ b/packages/teuchos/comm/test/Comm/reduce.cpp
+@@ -53,9 +53,6 @@ bool
+ testReduceSum (bool& success, std::ostream& out,
+ const int root, const Teuchos::Comm<int>& comm)
+ {
+-#ifdef HAVE_TEUCHOS_MPI
+- using Teuchos::MpiComm;
+-#endif // HAVE_TEUCHOS_MPI
+ using Teuchos::reduce;
+ using Teuchos::TypeNameTraits;
+ using std::endl;
+diff --git a/packages/teuchos/comm/test/Comm/scatter.cpp b/packages/teuchos/comm/test/Comm/scatter.cpp
+index 0ca961d2846..001009029c4 100644
+--- a/packages/teuchos/comm/test/Comm/scatter.cpp
++++ b/packages/teuchos/comm/test/Comm/scatter.cpp
+@@ -53,9 +53,6 @@ bool
+ testScatter (bool& success, std::ostream& out,
+ const int root, const Teuchos::Comm<int>& comm)
+ {
+-#ifdef HAVE_TEUCHOS_MPI
+- using Teuchos::MpiComm;
+-#endif // HAVE_TEUCHOS_MPI
+ using Teuchos::scatter;
+ using Teuchos::TypeNameTraits;
+ using std::endl;
diff --git a/gnu/packages/patches/tpetra-remove-duplicate-using.patch b/gnu/packages/patches/tpetra-remove-duplicate-using.patch
new file mode 100644
index 0000000000..e9cb2c6472
--- /dev/null
+++ b/gnu/packages/patches/tpetra-remove-duplicate-using.patch
@@ -0,0 +1,18 @@
+commit 919ceb0acbf4c6bc4f463433504a338c643612c2
+Author: Karen D. Devine <kddevin@sandia.gov>
+Date: Tue Feb 2 13:49:13 2021 -0700
+
+ tpetra: removed duplicate using statement #8673
+
+diff --git a/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp b/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
+index a76f78c41a8..69d4dc46d03 100644
+--- a/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
++++ b/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
+@@ -1094,7 +1094,6 @@ init (const keys_type& keys,
+
+ // Allocate the array of (key,value) pairs. Don't fill it with
+ // zeros, because we will fill it with actual data below.
+- using Kokkos::ViewAllocateWithoutInitializing;
+ typedef typename val_type::non_const_type nonconst_val_type;
+ nonconst_val_type val (ViewAllocateWithoutInitializing ("Tpetra::FixedHashTable::pairs"),
+ theNumKeys);