summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-08 00:03:17 -0400
committerVagrant Cascadian <vagrant@debian.org>2023-07-19 22:54:34 -0700
commitffbcc113df02293e1676310dbf3bfb23df8cae10 (patch)
tree4a17cbb597eac4fb1ab34503052ed3d165251424 /gnu/packages/patches
parented5dc3a25d858a394bb7db937a51d866c3cdc6ed (diff)
gnu: Add python-u-boot-pylib.
* gnu/packages/bootloaders.scm (python-u-boot-pylib): New variable. * gnu/packages/patches/u-boot-fix-u-boot-lib-build.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/u-boot-fix-u-boot-lib-build.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/u-boot-fix-u-boot-lib-build.patch b/gnu/packages/patches/u-boot-fix-u-boot-lib-build.patch
new file mode 100644
index 0000000000..233c437de6
--- /dev/null
+++ b/gnu/packages/patches/u-boot-fix-u-boot-lib-build.patch
@@ -0,0 +1,24 @@
+Submitted upstream (see:
+https://lists.denx.de/pipermail/u-boot/2023-July/521984.html)
+
+diff --git a/tools/u_boot_pylib/pyproject.toml b/tools/u_boot_pylib/pyproject.toml
+index 3f33caf6f8..037c5d629e 100644
+--- a/tools/u_boot_pylib/pyproject.toml
++++ b/tools/u_boot_pylib/pyproject.toml
+@@ -9,7 +9,7 @@ authors = [
+ { name="Simon Glass", email="sjg@chromium.org" },
+ ]
+ description = "U-Boot python library"
+-readme = "README.md"
++readme = "README.rst"
+ requires-python = ">=3.7"
+ classifiers = [
+ "Programming Language :: Python :: 3",
+@@ -20,3 +20,7 @@ classifiers = [
+ [project.urls]
+ "Homepage" = "https://u-boot.readthedocs.io"
+ "Bug Tracker" = "https://source.denx.de/groups/u-boot/-/issues"
++
++[tool.setuptools.packages.find]
++where = [".."]
++include = ["u_boot_pylib*"]