summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-09-25 21:13:12 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-10-04 17:58:22 +0300
commit151687a7a2a5fd6ea73393d1e748d8469fa3c08c (patch)
treed733cbda26d26e7b63b1163888eea9928198246d /gnu/packages/patches
parent37d0befca0cd346046b094025dcc2051047f39d8 (diff)
gnu: scilab: Update to 2023.1.0.
* gnu/packages/maths.scm (scilab): Update to 2023.1.0. [source] Use git-fetch. <modules>: Add (guix build utils) and (ice-9 ftw). <patches>: Add patch for hdf5 >= 1.10. <snippet>: Move contents of the "scilab" directory to its parents. Remove the other files and autogenerated files. [native-inputs]: Add autoconf, autoconf-archive, automake, bison, eigen, flex, libtool, ocaml and ocaml-findlib. [inputs]: Add ocaml-num, replace hdf5-1.8 by hdf5-1.14 and suitesparse-3 by suitesparse. [arguments]: Remove quasiquote. Add --enable-build-parser, --with-eigen-include=..., OCAMLC=... and OCAMLOPT=... to #:configure-flags. <#:phases>: Add fix-ocaml-num, remove-desktop-files, bootstrap-dynamic_link-scripts and build-parsers phases. Remove fixes for compilation and linker errors from the pre-build phase. [home-page]: Update URL. [description]: Add two spaces between sentences. [license]: Update to gpl2 and bsd-3. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/scilab-hdf5-1.8-api.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/gnu/packages/patches/scilab-hdf5-1.8-api.patch b/gnu/packages/patches/scilab-hdf5-1.8-api.patch
new file mode 100644
index 0000000000..8b453e4720
--- /dev/null
+++ b/gnu/packages/patches/scilab-hdf5-1.8-api.patch
@@ -0,0 +1,71 @@
+This patch fixes the compilation with hdf5 version >= 1.10. Adapted from
+https://aur.archlinux.org/cgit/aur.git/plain/hdf5_18_api.patch?h=scilab-git.
+
+diff -ur a/scilab/modules/hdf5/includes/HDF5Objects.h b/scilab/modules/hdf5/includes/HDF5Objects.h
+--- a/scilab/modules/hdf5/includes/HDF5Objects.h
++++ b/scilab/modules/hdf5/includes/HDF5Objects.h
+@@ -16,14 +16,12 @@
+ #ifndef __HDF5OBJECTS_H__
+ #define __HDF5OBJECTS_H__
+
+-#define H5_NO_DEPRECATED_SYMBOLS
+ #undef H5_USE_16_API
++#define H5_USE_18_API
+
+-#define H5Eset_auto_vers 2
+ #include <hdf5.h>
+ #include <hdf5_hl.h>
+
+-#undef H5_NO_DEPRECATED_SYMBOLS
+
+ //#define __HDF5OBJECTS_DEBUG__
+ //#define __HDF5ERROR_PRINT__
+diff -ur a/scilab/modules/hdf5/Makefile.am b/scilab/modules/hdf5/Makefile.am
+--- a/scilab/modules/hdf5/Makefile.am
++++ b/scilab/modules/hdf5/Makefile.am
+@@ -104,8 +104,7 @@
+ -DH5Gopen_vers=2 \
+ -DH5Tget_array_dims_vers=2 \
+ -DH5Acreate_vers=2 \
+- -DH5Rdereference_vers=2 \
+- -DNO_DEPRECATED_SYMBOLS
++ -DH5Rdereference_vers=2
+
+
+ libscihdf5_la_CPPFLAGS = \
+diff -ur a/scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp b/scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp
+--- a/scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp
++++ b/scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp
+@@ -13,6 +13,8 @@
+ *
+ */
+
++#define H5_USE_18_API
++
+ #include <vector>
+ #include "function.hxx"
+ #include "string.hxx"
+diff -ur a/scilab/modules/hdf5/src/c/h5_readDataFromFile.c b/scilab/modules/hdf5/src/c/h5_readDataFromFile.c
+--- a/scilab/modules/hdf5/src/c/h5_readDataFromFile.c
++++ b/scilab/modules/hdf5/src/c/h5_readDataFromFile.c
+@@ -13,7 +13,7 @@
+ *
+ */
+
+-#define H5_NO_DEPRECATED_SYMBOLS
++#define H5_USE_18_API
+
+ #ifndef _MSC_VER
+ #include <sys/time.h>
+diff -ur a/scilab/modules/hdf5/src/c/h5_readDataFromFile_v1.c b/scilab/modules/hdf5/src/c/h5_readDataFromFile_v1.c
+--- a/scilab/modules/hdf5/src/c/h5_readDataFromFile_v1.c
++++ b/scilab/modules/hdf5/src/c/h5_readDataFromFile_v1.c
+@@ -13,7 +13,7 @@
+ *
+ */
+
+-#define H5_NO_DEPRECATED_SYMBOLS
++#define H5_USE_18_API
+
+ #ifndef _MSC_VER
+ #include <sys/time.h>