summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
commit1b0ec97bce2db93ec4159a13fb0a184f012df4fe (patch)
tree33854abb7c6805448719ab37f3510150002ad725 /gnu/packages/patches
parentd47146562445c75a386d00471f6d2ab483d65fcb (diff)
gnu: xen: Build reproducibly
* gnu/packages/virtualization.scm (xen)[source]: Add patches. [arguments]: Add a new 'remove-cruft phase. * gnu/packages/patches/xen-docs-use-predictable-ordering.patch, * gnu/packages/patches/xen-remove-config.gz-timestamp.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them both.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/xen-docs-use-predictable-ordering.patch34
-rw-r--r--gnu/packages/patches/xen-remove-config.gz-timestamp.patch37
2 files changed, 71 insertions, 0 deletions
diff --git a/gnu/packages/patches/xen-docs-use-predictable-ordering.patch b/gnu/packages/patches/xen-docs-use-predictable-ordering.patch
new file mode 100644
index 0000000000..557da5775a
--- /dev/null
+++ b/gnu/packages/patches/xen-docs-use-predictable-ordering.patch
@@ -0,0 +1,34 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Sun Sep 24 02:00:00 2023 +0200
+Subject: xen: docs: Use predictable ordering.
+
+What follows was taken verbatim from Debian. See:
+https://sources.debian.org/patches/xen/4.14.5%2B94-ge49571868d-1/
+
+From: Maximilian Engelhardt <maxi@daemonizer.de>
+Date: Fri, 18 Dec 2020 21:42:34 +0100
+Subject: docs: use predictable ordering in generated documentation
+
+When the seq number is equal, sort by the title to get predictable
+output ordering. This is useful for reproducible builds.
+
+Signed-off-by: Maximilian Engelhardt <maxi@daemonizer.de>
+Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
+(cherry picked from commit e18dadc5b709290b8038a1cacb52bc3b3b69cf21)
+---
+ docs/xen-headers | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/docs/xen-headers b/docs/xen-headers
+index 5415563..8c434d7 100755
+--- a/docs/xen-headers
++++ b/docs/xen-headers
+@@ -331,7 +331,7 @@ sub output_index () {
+ <h2>Starting points</h2>
+ <ul>
+ END
+- foreach my $ic (sort { $a->{Seq} <=> $b->{Seq} } @incontents) {
++ foreach my $ic (sort { $a->{Seq} <=> $b->{Seq} or $a->{Title} cmp $b->{Title} } @incontents) {
+ $o .= "<li><a href=\"$ic->{Href}\">$ic->{Title}</a></li>\n";
+ }
+ $o .= "</ul>\n";
diff --git a/gnu/packages/patches/xen-remove-config.gz-timestamp.patch b/gnu/packages/patches/xen-remove-config.gz-timestamp.patch
new file mode 100644
index 0000000000..a7396c564d
--- /dev/null
+++ b/gnu/packages/patches/xen-remove-config.gz-timestamp.patch
@@ -0,0 +1,37 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Sun Sep 24 02:00:00 2023 +0200
+Subject: xen: docs: Use predictable ordering.
+
+What follows was taken verbatim from Debian. See:
+https://sources.debian.org/patches/xen/4.14.5%2B94-ge49571868d-1/
+
+From: =?utf-8?b?IkZyw6lkw6lyaWMgUGllcnJldCAoZmVwaXRyZSki?=
+ <frederic.pierret@qubes-os.org>
+Date: Wed, 4 Nov 2020 09:24:40 +0100
+Subject: xen: don't have timestamp inserted in config.gz
+MIME-Version: 1.0
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+This is for improving reproducible builds.
+
+Signed-off-by: Frédéric Pierret (fepitre) <frederic.pierret@qubes-os.org>
+Acked-by: Jan Beulich <jbeulich@suse.com>
+(cherry picked from commit 5816d327e44ab37ae08730f4c54a80835998f31f)
+---
+ xen/common/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/xen/common/Makefile b/xen/common/Makefile
+index 06881d0..32cd650 100644
+--- a/xen/common/Makefile
++++ b/xen/common/Makefile
+@@ -77,7 +77,7 @@ obj-$(CONFIG_HAS_DEVICE_TREE) += libfdt/
+
+ CONF_FILE := $(if $(patsubst /%,,$(KCONFIG_CONFIG)),$(XEN_ROOT)/xen/)$(KCONFIG_CONFIG)
+ config.gz: $(CONF_FILE)
+- gzip -c $< >$@
++ gzip -n -c $< >$@
+
+ config_data.o: config.gz
+