summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-09 17:50:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:23 +0300
commit3cede546d4e3a070faf08e2efa095dcdcbbbdfda (patch)
tree400d610a6c3b934baf3fab03e828c690bd79468d /gnu/packages/patches
parent26776d890d5bd87437fbf12726b4598599e5d531 (diff)
gnu: rust-adblock: Update to 0.7.5.
* gnu/packages/crates-io.scm (rust-adblock-0.4): Replace with rust-adblock-0.7.5. [source]: Remove patch. [arguments]: Add cargo-test-flags. [cargo-inputs]: Replace rust-cssparser-0.25 with 0.28, rust-selectors-0.21 with 0.23. [cargo-development-inputs]: Replace rust-criterion-0.3 with 0.4, rust-tokio-1.8 with rust-tokio. [native-inputs]: Remove pkg-config, openssl. * gnu/packages/patches/rust-adblock-ignore-live-tests.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/rust-adblock-ignore-live-tests.patch69
1 files changed, 0 insertions, 69 deletions
diff --git a/gnu/packages/patches/rust-adblock-ignore-live-tests.patch b/gnu/packages/patches/rust-adblock-ignore-live-tests.patch
deleted file mode 100644
index fc7f2858ff..0000000000
--- a/gnu/packages/patches/rust-adblock-ignore-live-tests.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From b83b5b453d3f7883ef4c12f84a7045486957c709 Mon Sep 17 00:00:00 2001
-From: Petr Hodina <phodina@protonmail.com>
-Date: Tue, 9 Nov 2021 17:02:54 +0100
-Subject: [PATCH] Ignore live tests.
-
-
-diff --git a/tests/live.rs b/tests/live.rs
-index b1a19fc..6bd4685 100644
---- a/tests/live.rs
-+++ b/tests/live.rs
-@@ -140,6 +140,7 @@ fn get_blocker_engine_deserialized_ios() -> Engine {
- }
-
- #[test]
-+#[ignore]
- fn check_live_specific_urls() {
- let mut engine = get_blocker_engine();
- {
-@@ -176,6 +177,7 @@ fn check_live_specific_urls() {
- }
-
- #[test]
-+#[ignore]
- fn check_live_deserialized_specific_urls() {
- let mut engine = get_blocker_engine_deserialized();
- {
-@@ -201,6 +203,7 @@ fn check_live_deserialized_specific_urls() {
- }
-
- #[test]
-+#[ignore]
- fn check_live_from_filterlists() {
- let engine = get_blocker_engine();
- let requests = load_requests();
-@@ -214,6 +217,7 @@ fn check_live_from_filterlists() {
- }
-
- #[test]
-+#[ignore]
- fn check_live_deserialized_file() {
- let engine = get_blocker_engine_deserialized();
- let requests = load_requests();
-@@ -243,6 +247,7 @@ fn check_live_deserialized_ios() {
-
- #[cfg(feature = "resource_assembler")]
- #[test]
-+#[ignore]
- fn check_live_redirects() {
- use adblock::resources::resource_assembler::assemble_web_accessible_resources;
-
-@@ -278,6 +283,7 @@ fn check_live_redirects() {
- }
-
- #[test]
-+#[ignore]
- /// Ensure that two different engines loaded from the same textual filter set serialize to
- /// identical buffers.
- fn stable_serialization() {
-@@ -291,6 +297,7 @@ fn stable_serialization() {
- }
-
- #[test]
-+#[ignore]
- /// Ensure that one engine's serialization result can be exactly reproduced by another engine after
- /// deserializing from it.
- fn stable_serialization_through_load() {
---
-2.33.1
-