summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-09 09:56:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-09 09:56:33 +0300
commit649ce7b433171a47e8a2819b849bfa88c736d0e9 (patch)
treeca4c7a4b3bfb13825737f72718e1377ee0ddbe1e /gnu/packages/patches
parent1bb29cd49c759a9af62b3d5c51ebd212bd3596c7 (diff)
parentc56d57110de1412d3529940d4f856611d123da66 (diff)
Merge branch 'rust-team'
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/rust-adblock-ignore-live-tests.patch69
-rw-r--r--gnu/packages/patches/rust-webbrowser-remove-unsupported-os.patch24
2 files changed, 24 insertions, 69 deletions
diff --git a/gnu/packages/patches/rust-adblock-ignore-live-tests.patch b/gnu/packages/patches/rust-adblock-ignore-live-tests.patch
deleted file mode 100644
index fc7f2858ff..0000000000
--- a/gnu/packages/patches/rust-adblock-ignore-live-tests.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From b83b5b453d3f7883ef4c12f84a7045486957c709 Mon Sep 17 00:00:00 2001
-From: Petr Hodina <phodina@protonmail.com>
-Date: Tue, 9 Nov 2021 17:02:54 +0100
-Subject: [PATCH] Ignore live tests.
-
-
-diff --git a/tests/live.rs b/tests/live.rs
-index b1a19fc..6bd4685 100644
---- a/tests/live.rs
-+++ b/tests/live.rs
-@@ -140,6 +140,7 @@ fn get_blocker_engine_deserialized_ios() -> Engine {
- }
-
- #[test]
-+#[ignore]
- fn check_live_specific_urls() {
- let mut engine = get_blocker_engine();
- {
-@@ -176,6 +177,7 @@ fn check_live_specific_urls() {
- }
-
- #[test]
-+#[ignore]
- fn check_live_deserialized_specific_urls() {
- let mut engine = get_blocker_engine_deserialized();
- {
-@@ -201,6 +203,7 @@ fn check_live_deserialized_specific_urls() {
- }
-
- #[test]
-+#[ignore]
- fn check_live_from_filterlists() {
- let engine = get_blocker_engine();
- let requests = load_requests();
-@@ -214,6 +217,7 @@ fn check_live_from_filterlists() {
- }
-
- #[test]
-+#[ignore]
- fn check_live_deserialized_file() {
- let engine = get_blocker_engine_deserialized();
- let requests = load_requests();
-@@ -243,6 +247,7 @@ fn check_live_deserialized_ios() {
-
- #[cfg(feature = "resource_assembler")]
- #[test]
-+#[ignore]
- fn check_live_redirects() {
- use adblock::resources::resource_assembler::assemble_web_accessible_resources;
-
-@@ -278,6 +283,7 @@ fn check_live_redirects() {
- }
-
- #[test]
-+#[ignore]
- /// Ensure that two different engines loaded from the same textual filter set serialize to
- /// identical buffers.
- fn stable_serialization() {
-@@ -291,6 +297,7 @@ fn stable_serialization() {
- }
-
- #[test]
-+#[ignore]
- /// Ensure that one engine's serialization result can be exactly reproduced by another engine after
- /// deserializing from it.
- fn stable_serialization_through_load() {
---
-2.33.1
-
diff --git a/gnu/packages/patches/rust-webbrowser-remove-unsupported-os.patch b/gnu/packages/patches/rust-webbrowser-remove-unsupported-os.patch
new file mode 100644
index 0000000000..9fea1e1665
--- /dev/null
+++ b/gnu/packages/patches/rust-webbrowser-remove-unsupported-os.patch
@@ -0,0 +1,24 @@
+--- Cargo.toml 2023-05-07 13:39:13.029066693 +0100
++++ Cargo.toml 2023-05-07 13:39:22.545138206 +0100
+@@ -67,21 +67,3 @@
+ [target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
+ version = "0.3"
+ features = ["Window"]
+-
+-[target."cfg(target_os = \"android\")".dependencies.jni]
+-version = "0.21"
+-
+-[target."cfg(target_os = \"android\")".dependencies.ndk-context]
+-version = "0.1"
+-
+-[target."cfg(target_os = \"android\")".dev-dependencies.ndk-glue]
+-version = ">= 0.3, <= 0.7"
+-
+-[target."cfg(target_os = \"ios\")".dependencies.objc]
+-version = "0.2.7"
+-
+-[target."cfg(target_os = \"ios\")".dependencies.raw-window-handle]
+-version = "0.5.0"
+-
+-[target."cfg(target_os = \"macos\")".dependencies.core-foundation]
+-version = "0.9"