summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-18 22:30:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-18 22:32:20 +0300
commita515f8b1d8fbda4ea791762fc3987bd5411de077 (patch)
tree763e9c4171eb6b11c70833d0b06f482f011dcba1 /gnu/packages/patches
parent926a79a86aa89d3b743fd3405b49e37493f7792d (diff)
gnu: tor: Update to 0.4.8.6.
* gnu/packages/tor.scm (tor): Update to 0.4.8.6. [source]: Remove patch. * gnu/packages/patches/tor-remove-defensive-assert.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/tor-remove-defensive-assert.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/patches/tor-remove-defensive-assert.patch b/gnu/packages/patches/tor-remove-defensive-assert.patch
deleted file mode 100644
index 7207ec867a..0000000000
--- a/gnu/packages/patches/tor-remove-defensive-assert.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-This patch removes a call to `tor_assert_nonfatal_unreached()` in
-`relay_key_is_unavailable_()` that is only called when Tor is compiled
-without relay support.
-
-Unfortunately, the non-fatal assertion causes a BUG log
-message to appear for clients when they start up without relay support
-for each CPU worker we spawn. This makes it spotting issues during
-bootstrap harder particularly for our iOS developers.
-
-Since the call sites to `get_master_identity_key()` handles `NULL`
-values already, we do not think this will be an issue later on.
-
-Reported by Benjamin Erhart (@tla) from Guardian Project.
-
-Fixes tpo/core/tor#40848.
-
-diff --git a/src/feature/relay/routerkeys.h b/src/feature/relay/routerkeys.h
-index 7b6d80773c..b97615a9c9 100644
---- a/src/feature/relay/routerkeys.h
-+++ b/src/feature/relay/routerkeys.h
-@@ -53,7 +53,6 @@ void routerkeys_free_all(void);
- static inline void *
- relay_key_is_unavailable_(void)
- {
-- tor_assert_nonfatal_unreached();
- return NULL;
- }
- #define relay_key_is_unavailable(type) \