summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-01-11 11:29:00 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-01-11 12:06:12 +0100
commit21cf0d36db9f02b3da976088b5ab466822d16625 (patch)
tree913e347c63bdf5d3c578d4be0d0ed8b166a7d339 /gnu/packages/patches
parentb54b3f5419849286611279231d8a2c61d3e935b4 (diff)
gnu: guile: Fix tests on emulated architectures.
The stack overflow test limits the virtual memory size using setrlimit with RLIMIT_AS argument. This is ignored when using QEMU transparent emulation, causing the test to crash. * gnu/packages/patches/guile-2.2-skip-so-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/guile.scm (guile-3.0-latest): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/guile-2.2-skip-so-test.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-2.2-skip-so-test.patch b/gnu/packages/patches/guile-2.2-skip-so-test.patch
new file mode 100644
index 0000000000..e7c2594e91
--- /dev/null
+++ b/gnu/packages/patches/guile-2.2-skip-so-test.patch
@@ -0,0 +1,23 @@
+Skip 'test-stack-overflow' that crashes when using QEMU transparent emulation.
+
+--- a/test-suite/standalone/Makefile.in 1970-01-01 01:00:01.000000000 +0100
++++ b/test-suite/standalone/Makefile.in 2021-01-11 10:59:31.606269449 +0100
+@@ -102,8 +102,7 @@
+ test-scm-to-latin1-string$(EXEEXT) test-scm-values$(EXEEXT) \
+ test-scm-c-bind-keyword-arguments$(EXEEXT) \
+ test-srfi-4$(EXEEXT) $(am__append_6) $(am__EXEEXT_1) \
+- test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT) \
+- test-stack-overflow
++ test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT)
+ check_PROGRAMS = test-num2integral$(EXEEXT) test-round$(EXEEXT) \
+ test-foreign-object-c$(EXEEXT) test-list$(EXEEXT) \
+ test-unwind$(EXEEXT) test-conversion$(EXEEXT) \
+@@ -1938,7 +1937,7 @@
+ test-command-line-encoding test-command-line-encoding2 \
+ test-language test-guild-compile $(am__append_3) \
+ test-foreign-object-scm test-fast-slot-ref test-mb-regexp \
+- test-use-srfi $(am__append_5) test-stack-overflow
++ test-use-srfi $(am__append_5)
+ BUILT_SOURCES = $(am__append_2)
+ EXTRA_DIST = test-import-order-a.scm test-import-order-b.scm \
+ test-import-order-c.scm test-import-order-d.scm \