summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2022-10-09 02:08:24 -0300
committerLudovic Courtès <ludo@gnu.org>2022-10-09 22:32:14 +0200
commitbdb13dfd29e7b6028f23ca5faa4983848375e7c5 (patch)
treed8bb356c8079c99a2c3690836eda3a5f18f2d0f6 /gnu/packages/patches
parentfa3ba0143fee0b8ccbd0371cc37c1435d4f2a68f (diff)
gnu: public-inbox: Update to 1.9.0.
The patch is included in version 1.9.0, so remove it from Guix. On i686-linux, test t/pop3d.t fails unless the File::FcntlLock module is present so add it. * gnu/packages/patches/public-inbox-fix-spawn-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/mail.scm (public-inbox)[version]: Change to 1.9.0. [source]: Update hash. Remove patch. [inputs]: Add perl-file-fcntllock if target is x86-32. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/public-inbox-fix-spawn-test.patch43
1 files changed, 0 insertions, 43 deletions
diff --git a/gnu/packages/patches/public-inbox-fix-spawn-test.patch b/gnu/packages/patches/public-inbox-fix-spawn-test.patch
deleted file mode 100644
index 2739b1974d..0000000000
--- a/gnu/packages/patches/public-inbox-fix-spawn-test.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 5593489d9c3ce22b1942f35c7ebb0e06fcf2bfa8 Mon Sep 17 00:00:00 2001
-From: Thiago Jung Bauermann <bauermann@kolabnow.com>
-Date: Fri, 10 Jun 2022 12:39:18 -0300
-Subject: [PATCH] t/spawn: Find invalid PID to try to join its process group
-
-In the container used to build packages of the GNU Guix distribution, PID 1
-runs as the same user as the test so this spawn that should fail actually
-succeeds.
-
-Fix the problem by going through different PIDs and picking one that
-either doesn't exist or we aren't allowed to signal.
----
-
-This patch is taken from the public-inbox repository and will appear in the
-release after v1.8.
-
- t/spawn.t | 13 ++++++++++++-
- 1 file changed, 12 insertions(+), 1 deletion(-)
-
-diff --git a/t/spawn.t b/t/spawn.t
-index 6168c1f6171c..5fc99a2a101c 100644
---- a/t/spawn.t
-+++ b/t/spawn.t
-@@ -24,7 +24,18 @@ SKIP: {
- is(waitpid($pid, 0), $pid, 'waitpid succeeds on spawned process');
- is($?, 0, 'true exited successfully');
- pipe(my ($r, $w)) or BAIL_OUT;
-- $pid = eval { spawn(['true'], undef, { pgid => 1, 2 => $w }) };
-+
-+ # Find invalid PID to try to join its process group.
-+ my $wrong_pgid = 1;
-+ for (my $i=0x7fffffff; $i >= 2; $i--) {
-+ if (kill(0, $i) == 0) {
-+ $wrong_pgid = $i;
-+ last;
-+ }
-+ }
-+
-+ # Test spawn behavior when it can't join the requested process group.
-+ $pid = eval { spawn(['true'], undef, { pgid => $wrong_pgid, 2 => $w }) };
- close $w;
- my $err = do { local $/; <$r> };
- # diag "$err ($@)";