summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndrew Patterson <andrewpatt7@gmail.com>2022-11-17 21:53:01 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-19 12:58:12 +0100
commitcc08d374b21f1326c2d70d5af84b56c0714a0885 (patch)
tree1fb476ab5763e1daba5b6cba8c3a8f80ed2f7ff6 /gnu/packages/patches
parent854bdb7ba9abd6392da823f723553df03077e9a7 (diff)
gnu: sbcl: Fix build on aarch64.
sbcl 2.2.10 currently doesn't build on aarch64. Upstream has fixed the issue (https://bugs.launchpad.net/sbcl/+bug/1996942), but this patch is needed until the next release. * gnu/packages/patches/sbcl-fix-build-on-arm64-with-clisp-as-host.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/lisp.scm (sbcl)[source]: Use it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/sbcl-fix-build-on-arm64-with-clisp-as-host.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/sbcl-fix-build-on-arm64-with-clisp-as-host.patch b/gnu/packages/patches/sbcl-fix-build-on-arm64-with-clisp-as-host.patch
new file mode 100644
index 0000000000..4fe3ed16db
--- /dev/null
+++ b/gnu/packages/patches/sbcl-fix-build-on-arm64-with-clisp-as-host.patch
@@ -0,0 +1,27 @@
+From 944f53fb00794f4bc96700dd14df1e88b6cd5623 Mon Sep 17 00:00:00 2001
+From: Christophe Rhodes <csr21@cantab.net>
+Date: Thu, 17 Nov 2022 22:29:26 +0000
+Subject: [PATCH] Fix build on arm64 with clisp as host
+
+Make sure the offset constants are defined while compiling vm.lisp.
+---
+ src/compiler/arm64/vm.lisp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/compiler/arm64/vm.lisp b/src/compiler/arm64/vm.lisp
+index ae6d7c7fa..2a151be58 100644
+--- a/src/compiler/arm64/vm.lisp
++++ b/src/compiler/arm64/vm.lisp
+@@ -23,7 +23,8 @@
+ (macrolet ((defreg (name offset)
+ (let ((offset-sym (symbolicate name "-OFFSET")))
+ `(progn
+- (defconstant ,offset-sym ,offset)
++ (eval-when (:compile-toplevel :load-toplevel :execute)
++ (defconstant ,offset-sym ,offset))
+ (setf (svref *register-names* ,offset-sym) ,(symbol-name name)))))
+
+ (defregset (name &rest regs)
+--
+2.30.2
+