summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-09 19:47:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-09 19:49:06 +0200
commit0f1adf454d5fa96291b94dbdbd34640b8c581116 (patch)
treebcb4065e2d91d46b1d1c1ada4a9c086958833d66 /gnu/packages/patches
parenta864d563025f7408204af8540f8611a56bd3c939 (diff)
gnu: acl: Fix test regression with perl-5.26.
* gnu/packages/acl.scm (acl)[source]: Add patch. * gnu/packages/patches/acl-fix-perl-regex.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/acl-fix-perl-regex.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/acl-fix-perl-regex.patch b/gnu/packages/patches/acl-fix-perl-regex.patch
new file mode 100644
index 0000000000..f682abc058
--- /dev/null
+++ b/gnu/packages/patches/acl-fix-perl-regex.patch
@@ -0,0 +1,22 @@
+This can be removed with the next acl release
+
+---
+ test/run | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/run b/test/run
+index 2cf52e8..4627cd2 100755
+--- a/test/run
++++ b/test/run
+@@ -70,7 +70,7 @@ for (;;) {
+ if (defined $line) {
+ # Substitute %VAR and %{VAR} with environment variables.
+ $line =~ s[%(\w+)][$ENV{$1}]eg;
+- $line =~ s[%{(\w+)}][$ENV{$1}]eg;
++ $line =~ s[%\{(\w+)\}][$ENV{$1}]eg;
+ }
+ if (defined $line) {
+ if ($line =~ s/^\s*< ?//) {
+--
+2.15.0
+