summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-03 17:03:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-03 17:03:56 +0200
commit30e12b9664d774aca3948b1fa2e0aee6af09ca40 (patch)
tree483e1bfaad4671b922bb070a35da3ada819f9e50 /gnu/packages/patches
parent136b7d81f0eb713783e9ea7cf7f260a2b6252dfd (diff)
parent3092f1b835d79655eecb2f8a79dda20ad9ba6bd6 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gnucash-fix-test-transaction-failure.patch54
-rw-r--r--gnu/packages/patches/gtksourceview-2-add-default-directory.patch33
-rw-r--r--gnu/packages/patches/libevent-2.1-dns-tests.patch26
-rw-r--r--gnu/packages/patches/libevent-2.1-skip-failing-test.patch24
-rw-r--r--gnu/packages/patches/supertux-fix-build-with-gcc5.patch75
-rw-r--r--gnu/packages/patches/supertux-unbundle-squirrel.patch53
-rw-r--r--gnu/packages/patches/txr-shell.patch59
7 files changed, 220 insertions, 104 deletions
diff --git a/gnu/packages/patches/gnucash-fix-test-transaction-failure.patch b/gnu/packages/patches/gnucash-fix-test-transaction-failure.patch
deleted file mode 100644
index 7b1b29f06c..0000000000
--- a/gnu/packages/patches/gnucash-fix-test-transaction-failure.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-# This patch was submitted upstream to: https://bugs.gnucash.org/show_bug.cgi?id=797008.
-From c20d74bebca516d0e391724202aad511967fe109 Mon Sep 17 00:00:00 2001
-From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-Date: Wed, 2 Jan 2019 14:46:28 -0500
-Subject: [PATCH] tests: Fix a test failure in test-transaction.scm.
-
-With the New Year upon us, a test which was hard-coded to use 2018 now
-failed.
-
-Fixes issue #797008 (see:
-https://bugs.gnucash.org/show_bug.cgi?id=797008).
-
-* gnucash/report/standard-reports/test/test-transaction.scm:
-(trep-tests): Use the current year in the test string instead of a
-static one.
----
- gnucash/report/standard-reports/test/test-transaction.scm | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/gnucash/report/standard-reports/test/test-transaction.scm b/gnucash/report/standard-reports/test/test-transaction.scm
-index 755aba298..ae3fbd5c1 100644
---- a/gnucash/report/standard-reports/test/test-transaction.scm
-+++ b/gnucash/report/standard-reports/test/test-transaction.scm
-@@ -5,6 +5,7 @@
- (use-modules (gnucash report stylesheets))
- (use-modules (gnucash report report-system))
- (use-modules (gnucash report report-system test test-extras))
-+(use-modules (srfi srfi-19))
- (use-modules (srfi srfi-64))
- (use-modules (gnucash engine test srfi64-extras))
- (use-modules (sxml simple))
-@@ -643,7 +644,8 @@
- (set-option! options "General" "Show original currency amount" #t)
- (set-option! options "Sorting" "Primary Key" 'date)
- (set-option! options "Sorting" "Primary Subtotal for Date Key" 'none)
-- (let* ((sxml (options->sxml options "dual columns")))
-+ (let* ((sxml (options->sxml options "dual columns"))
-+ (current-year (date->string (current-date) "~y")))
- (test-equal "dual amount column, with original currency headers"
- (list "Date" "Num" "Description" "Memo/Notes" "Account"
- "Debit (USD)" "Credit (USD)" "Debit" "Credit")
-@@ -652,7 +654,8 @@
- (list "Grand Total" "$2,280.00" "$2,280.00")
- (get-row-col sxml -1 #f))
- (test-equal "dual amount column, first transaction correct"
-- (list "01/03/18" "$103 income" "Root.Asset.Bank" "$103.00" "$103.00")
-+ (list (string-append "01/03/" current-year) "$103 income"
-+ "Root.Asset.Bank" "$103.00" "$103.00")
- (get-row-col sxml 1 #f)))
- )
-
---
-2.19.0
-
diff --git a/gnu/packages/patches/gtksourceview-2-add-default-directory.patch b/gnu/packages/patches/gtksourceview-2-add-default-directory.patch
new file mode 100644
index 0000000000..c4b5052b81
--- /dev/null
+++ b/gnu/packages/patches/gtksourceview-2-add-default-directory.patch
@@ -0,0 +1,33 @@
+From fc401acb15f15d487c942437b6fb429289dd3c67 Mon Sep 17 00:00:00 2001
+From: Julien Lepiller <julien@lepiller.eu>
+Date: Fri, 31 May 2019 13:22:25 +0200
+Subject: [PATCH] Add installation directory as a default directory.
+
+In Guix, this library is installed in a separate directory in the store,
+and it's typically not installed system-wide in a fixed directory. Add
+the store path to the set of default directories so dependents can find
+default langs and source highlighting scheme.
+---
+ gtksourceview/gtksourceview-utils.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/gtksourceview/gtksourceview-utils.c b/gtksourceview/gtksourceview-utils.c
+index 6f06bab..c3467d5 100644
+--- a/gtksourceview/gtksourceview-utils.c
++++ b/gtksourceview/gtksourceview-utils.c
+@@ -66,6 +66,12 @@ _gtk_source_view_get_default_dirs (const char *basename,
+ basename,
+ NULL));
+
++ /* installed dir */
++ g_ptr_array_add (dirs, g_build_filename (DATADIR,
++ SOURCEVIEW_DIR,
++ basename,
++ NULL));
++
+ g_ptr_array_add (dirs, NULL);
+
+ return (gchar**) g_ptr_array_free (dirs, FALSE);
+--
+2.21.0
+
diff --git a/gnu/packages/patches/libevent-2.1-dns-tests.patch b/gnu/packages/patches/libevent-2.1-dns-tests.patch
deleted file mode 100644
index 091752a49d..0000000000
--- a/gnu/packages/patches/libevent-2.1-dns-tests.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Disable tests that rely on usable DNS lookups, which aren't available
-in build chroots.
-
---- libevent-2.0.21-stable/test/regress_dns.c 2013-01-20 22:32:09.000000000 +0100
-+++ libevent-2.0.21-stable/test/regress_dns.c 2013-01-20 22:32:30.000000000 +0100
-@@ -2120,10 +2120,6 @@
-
- struct testcase_t dns_testcases[] = {
- DNS_LEGACY(server, TT_FORK|TT_NEED_BASE),
-- DNS_LEGACY(gethostbyname, TT_FORK|TT_NEED_BASE|TT_NEED_DNS|TT_OFF_BY_DEFAULT),
-- DNS_LEGACY(gethostbyname6, TT_FORK|TT_NEED_BASE|TT_NEED_DNS|TT_OFF_BY_DEFAULT),
-- DNS_LEGACY(gethostbyaddr, TT_FORK|TT_NEED_BASE|TT_NEED_DNS|TT_OFF_BY_DEFAULT),
-- { "resolve_reverse", dns_resolve_reverse, TT_FORK|TT_OFF_BY_DEFAULT, NULL, NULL },
- { "search_empty", dns_search_empty_test, TT_FORK|TT_NEED_BASE, &basic_setup, NULL },
- { "search", dns_search_test, TT_FORK|TT_NEED_BASE, &basic_setup, NULL },
- { "search_lower", dns_search_lower_test, TT_FORK|TT_NEED_BASE, &basic_setup, NULL },
-@@ -2163,9 +2159,6 @@
-
- { "client_fail_requests", dns_client_fail_requests_test,
- TT_FORK|TT_NEED_BASE, &basic_setup, NULL },
-- { "client_fail_requests_getaddrinfo",
-- dns_client_fail_requests_getaddrinfo_test,
-- TT_FORK|TT_NEED_BASE, &basic_setup, NULL },
-
- END_OF_TESTCASES
- };
diff --git a/gnu/packages/patches/libevent-2.1-skip-failing-test.patch b/gnu/packages/patches/libevent-2.1-skip-failing-test.patch
deleted file mode 100644
index d9ea1d422d..0000000000
--- a/gnu/packages/patches/libevent-2.1-skip-failing-test.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-These fail on 32-bit due to an overflow bug in the test program.
-
-See test/regress_util.c:1448.
-
-Upstream bug URL:
-
-https://github.com/libevent/libevent/issues/452
-
-diff --git a/test/regress_util.c b/test/regress_util.c
-index ef6a1487..4de501fc 100644
---- a/test/regress_util.c
-+++ b/test/regress_util.c
-@@ -1413,9 +1413,9 @@ static struct date_rfc1123_case {
- { 1323648000, "Mon, 12 Dec 2011 00:00:00 GMT"},
- #ifndef _WIN32
- /** In win32 case we have max "23:59:59 January 18, 2038, UTC" for time32 */
-- { 4294967296, "Sun, 07 Feb 2106 06:28:16 GMT"} /* 2^32 */,
-+ //{ 4294967296, "Sun, 07 Feb 2106 06:28:16 GMT"} /* 2^32 */,
- /** In win32 case we have max "23:59:59, December 31, 3000, UTC" for time64 */
-- {253402300799, "Fri, 31 Dec 9999 23:59:59 GMT"} /* long long future no one can imagine */,
-+ //{253402300799, "Fri, 31 Dec 9999 23:59:59 GMT"} /* long long future no one can imagine */,
- { 1456704000, "Mon, 29 Feb 2016 00:00:00 GMT"} /* leap year */,
- #endif
- { 1435708800, "Wed, 01 Jul 2015 00:00:00 GMT"} /* leap second */,
diff --git a/gnu/packages/patches/supertux-fix-build-with-gcc5.patch b/gnu/packages/patches/supertux-fix-build-with-gcc5.patch
new file mode 100644
index 0000000000..6393215ca1
--- /dev/null
+++ b/gnu/packages/patches/supertux-fix-build-with-gcc5.patch
@@ -0,0 +1,75 @@
+Taken from https://github.com/SuperTux/supertux/commit/a75317ef0a94847d9b6a7833b9c6652ef29edde3.
+This patch fixes building with gcc versions earlier than 6.
+
+From a75317ef0a94847d9b6a7833b9c6652ef29edde3 Mon Sep 17 00:00:00 2001
+From: Ingo Ruhnke <grumbel@gmail.com>
+Date: Fri, 28 Dec 2018 22:45:35 +0100
+Subject: [PATCH] Add workaround for backwards compatibilty with gcc5
+
+Fixes #1014
+---
+ src/video/gl/gl_painter.cpp | 11 ++++++-----
+ src/video/ttf_surface.cpp | 16 +++++++++-------
+ 2 files changed, 15 insertions(+), 12 deletions(-)
+
+diff --git a/src/video/gl/gl_painter.cpp b/src/video/gl/gl_painter.cpp
+index 5e0d1e7b1e..32fb7a09b6 100644
+--- a/src/video/gl/gl_painter.cpp
++++ b/src/video/gl/gl_painter.cpp
+@@ -37,12 +37,13 @@ namespace {
+
+ inline std::tuple<GLenum, GLenum> blend_factor(Blend blend)
+ {
++ using B = std::tuple<GLenum, GLenum>;
+ switch(blend) {
+- case Blend::NONE: return {GL_ONE, GL_ZERO};
+- case Blend::BLEND: return {GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA};
+- case Blend::ADD: return {GL_SRC_ALPHA, GL_ONE};
+- case Blend::MOD: return {GL_DST_COLOR, GL_ZERO};
+- default: return {GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA};
++ case Blend::NONE: return B(GL_ONE, GL_ZERO);
++ case Blend::BLEND: return B(GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA);
++ case Blend::ADD: return B(GL_SRC_ALPHA, GL_ONE);
++ case Blend::MOD: return B(GL_DST_COLOR, GL_ZERO);
++ default: return B(GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA);
+ }
+ }
+
+diff --git a/src/video/ttf_surface.cpp b/src/video/ttf_surface.cpp
+index 7c9505004f..b41d67b2c8 100644
+--- a/src/video/ttf_surface.cpp
++++ b/src/video/ttf_surface.cpp
+@@ -55,12 +55,13 @@ TTFSurface::create(const TTFFont& font, const std::string& text)
+ SDL_SetSurfaceColorMod(text_surface.get(), 0, 0, 0);
+ SDL_SetSurfaceBlendMode(text_surface.get(), SDL_BLENDMODE_BLEND);
+
++ using P = std::tuple<int, int>;
+ const std::initializer_list<std::tuple<int, int> > positions[] = {
+ {},
+- {{0, 0}},
+- {{-1, 0}, {1, 0}, {0, -1}, {0, 1}},
+- {{-2, 0}, {2, 0}, {0, -2}, {0, 2},
+- {-1, -1}, {1, -1}, {-1, 1}, {1, 1}}
++ {P{0, 0}},
++ {P{-1, 0}, P{1, 0}, P{0, -1}, P{0, 1}},
++ {P{-2, 0}, P{2, 0}, P{0, -2}, P{0, 2},
++ P{-1, -1}, P{1, -1}, P{-1, 1}, P{1, 1}}
+ };
+
+ int shadow_size = std::min(2, font.get_shadow_size());
+@@ -77,11 +78,12 @@ TTFSurface::create(const TTFFont& font, const std::string& text)
+ SDL_SetSurfaceColorMod(text_surface.get(), 0, 0, 0);
+ SDL_SetSurfaceBlendMode(text_surface.get(), SDL_BLENDMODE_BLEND);
+
++ using P = std::tuple<int, int>;
+ const std::initializer_list<std::tuple<int, int> > positions[] = {
+ {},
+- {{-1, 0}, {1, 0}, {0, -1}, {0, 1}},
+- {{-2, 0}, {2, 0}, {0, -2}, {0, 2},
+- {-1, -1}, {1, -1}, {-1, 1}, {1, 1}}
++ {P{-1, 0}, P{1, 0}, P{0, -1}, P{0, 1}},
++ {P{-2, 0}, P{2, 0}, P{0, -2}, P{0, 2},
++ P{-1, -1}, P{1, -1}, P{-1, 1}, P{1, 1}}
+ };
+
+ int border = std::min(2, font.get_border());
diff --git a/gnu/packages/patches/supertux-unbundle-squirrel.patch b/gnu/packages/patches/supertux-unbundle-squirrel.patch
new file mode 100644
index 0000000000..054183b75f
--- /dev/null
+++ b/gnu/packages/patches/supertux-unbundle-squirrel.patch
@@ -0,0 +1,53 @@
+diff -ur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2019-05-24 17:58:19.693090158 -0400
++++ b/CMakeLists.txt 2019-05-24 17:57:43.349473252 -0400
+@@ -375,44 +375,15 @@
+
+ include(ConfigureChecks)
+
+-
+-## Also build external/squirrel
+-
+-if(NOT EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/external/squirrel/CMakeLists.txt)
+- message(FATAL_ERROR "squirrel submodule is not checked out or ${CMAKE_CURRENT_SOURCE_DIR}/external/squirrel/CMakeLists.txt is missing")
+-endif()
+-
+ set(SQUIRREL_PREFIX ${CMAKE_BINARY_DIR}/squirrel/ex)
+-ExternalProject_Add(squirrel
+- SOURCE_DIR "${CMAKE_SOURCE_DIR}/external/squirrel/"
+- CMAKE_ARGS
+- -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE}
+- -DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
+- -DCMAKE_C_FLAGS=${CMAKE_C_FLAGS}
+- -DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
+- -DCMAKE_CXX_FLAGS=${CMAKE_CXX_FLAGS}
+- -DCMAKE_INSTALL_PREFIX=${SQUIRREL_PREFIX}
+- -DINSTALL_INC_DIR=include)
+-
+-if(WIN32)
+- add_library(squirrel_lib SHARED IMPORTED)
+- set_target_properties(squirrel_lib PROPERTIES IMPORTED_LOCATION "${SQUIRREL_PREFIX}/bin/${CMAKE_SHARED_LIBRARY_PREFIX}squirrel${CMAKE_SHARED_LIBRARY_SUFFIX}")
+- set_target_properties(squirrel_lib PROPERTIES IMPORTED_IMPLIB "${SQUIRREL_PREFIX}/lib/squirrel${CMAKE_LINK_LIBRARY_SUFFIX}")
+- add_library(sqstdlib_lib SHARED IMPORTED)
+- set_target_properties(sqstdlib_lib PROPERTIES IMPORTED_LOCATION "${SQUIRREL_PREFIX}/bin/${CMAKE_SHARED_LIBRARY_PREFIX}sqstdlib${CMAKE_SHARED_LIBRARY_SUFFIX}")
+- set_target_properties(sqstdlib_lib PROPERTIES IMPORTED_IMPLIB "${SQUIRREL_PREFIX}/lib/sqstdlib${CMAKE_LINK_LIBRARY_SUFFIX}")
+-
+- #For debug run purposes
+- configure_file("${CMAKE_CURRENT_SOURCE_DIR}/mk/msvc/run_supertux.bat.in" "${PROJECT_BINARY_DIR}/run_supertux.bat")
+-else()
+- add_library(squirrel_lib STATIC IMPORTED)
+- set_target_properties(squirrel_lib PROPERTIES IMPORTED_LOCATION "${SQUIRREL_PREFIX}/lib/${CMAKE_STATIC_LIBRARY_PREFIX}squirrel_static${CMAKE_STATIC_LIBRARY_SUFFIX}")
+- add_library(sqstdlib_lib STATIC IMPORTED)
+- set_target_properties(sqstdlib_lib PROPERTIES IMPORTED_LOCATION "${SQUIRREL_PREFIX}/lib/${CMAKE_STATIC_LIBRARY_PREFIX}sqstdlib_static${CMAKE_STATIC_LIBRARY_SUFFIX}")
+-endif()
+
+ include_directories(SYSTEM ${SQUIRREL_PREFIX}/include)
+
++add_library(squirrel_lib SHARED IMPORTED)
++set_target_properties(squirrel_lib PROPERTIES IMPORTED_LOCATION "${SQUIRREL_PREFIX}/lib/${CMAKE_SHARED_LIBRARY_PREFIX}squirrel${CMAKE_SHARED_LIBRARY_SUFFIX}")
++add_library(sqstdlib_lib SHARED IMPORTED)
++set_target_properties(sqstdlib_lib PROPERTIES IMPORTED_LOCATION "${SQUIRREL_PREFIX}/lib/${CMAKE_SHARED_LIBRARY_PREFIX}sqstdlib${CMAKE_SHARED_LIBRARY_SUFFIX}")
++
+ ## Also build external/tinygettext
+
+ if(NOT EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/external/tinygettext/CMakeLists.txt)
diff --git a/gnu/packages/patches/txr-shell.patch b/gnu/packages/patches/txr-shell.patch
new file mode 100644
index 0000000000..a4abb73eac
--- /dev/null
+++ b/gnu/packages/patches/txr-shell.patch
@@ -0,0 +1,59 @@
+Use the current shell instead of trying to find another one and
+failing to do so.
+
+diff --git a/configure b/configure
+index f1adb919..7891b4dc 100755
+--- a/configure
++++ b/configure
+@@ -26,28 +26,6 @@
+ # OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+-#
+-# The #!/bin/sh might be some legacy piece of crap,
+-# not even up to 1990 POSIX.2 spec. So the first step
+-# is to look for a better shell in some known places
+-# and re-execute ourselves with that interpreter.
+-#
+-
+-if test x$txr_shell = x ; then
+- for shell in /bin/bash /usr/bin/bash /usr/xpg4/bin/sh ; do
+- if test -x $shell ; then
+- txr_shell=$shell
+- break
+- fi
+- done
+- if test x$txr_shell = x ; then
+- echo "No known POSIX shell found: falling back on /bin/sh, which may not work"
+- txr_shell=/bin/sh
+- fi
+- export txr_shell
+- exec $txr_shell $0 ${@+"$@"}
+-fi
+-
+ set -u
+
+ #
+@@ -190,13 +168,6 @@ while [ $# -gt 0 ] ; do
+ exit 1
+ fi
+
+- eval "var_exists=\${$var+y}"
+-
+- if [ "$var_exists" != y ] ; then
+- printf "$0: nonexistent option: '%s'\n" "$1"
+- exit 1
+- fi
+-
+ eval "$var='$val'"
+
+ eval "var_given_exists=\${${var}_given+y}"
+@@ -208,6 +179,8 @@ while [ $# -gt 0 ] ; do
+ shift
+ done
+
++txr_shell=$CONFIG_SHELL
++
+ #
+ # If --help was given (or --help=<nonempty> or help=<nonempty>) then
+ # print help and exit. The termination status is failed, to indicate