summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-30 21:35:56 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-05 10:56:35 +0100
commit6211aadf4b396318bb35617256643e33f1e1997e (patch)
treebb4966b4c4fd6faa1f25e0d53a3f4e5b84ca680f /gnu/packages/patches
parent9f5bd38f94fbde4806296756d77f887ffcb29b58 (diff)
gnu: kde-frameworks: Update to 5.39.0.
Beside simple updating: - ktexteditor: Add input. - kdelibs4support: Enable test kmimetypetest, disable test kuniqueapptest. - kimageformats: Make the plugins available for tests. - krunner: Make old tests pass again. Blacklist a failing new test. * gnu/packages/kde-frameworks.scm (attica, baloo, bluez-qt, breeze-icons, extra-cmake-modules, kactivities, kactivities-stats, kapidox, karchive, kauth, kbookmarks, kcmutils, kcodecs, kcompletion, kconfig, kconfigwidgets, kcoreaddons, kcrash, kdbusaddons, kdeclarative, kded, kde-frameworkintegration, kdelibs4support, kdesignerplugin, kdesu, kdewebkit, kdnssd, kdoctools, kemoticons, kfilemetadata, kglobalaccel, kguiaddons, khtml, ki18n, kiconthemes, kidletime, kimageformats, kinit, kio, kitemmodels, kitemviews, kjobwidgets, kjs, kjsembed, kmediaplayer, knewstuff, knotifications, knotifyconfig, kpackage, kparts, kpeople, kplotting, kpty, kross, krunner, kservice, ksyntaxhighlighting, ktextwidgets, kunitconversion, kwallet, kwayland, kwidgetsaddons, kwindowsystem, kxmlgui, kxmlrpcclient, modemmanager-qt, networkmanager-qt, oxygen-icons, plasma-framework, prison, solid, sonnet, threadweaver): Update to 5.39.0 (ktexteditor) Update to 5.39.0. [source]: Add patch. [inputs]: Add qtdeclarative. (kdelibs4support): Update to 5.39.0. [#:phase check-post-install]: Remove kmimetypetest from and add kuniqueapptest to list of test to be excluded when running ctest. (kimageformats): Update to 5.39.0. [#:phase check-setup] Make the plugins available for tests. * gnu/packages/patches/ktexteditor-5.39.0-autotests-dependencies.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ktexteditor-5.39.0-autotests-dependencies.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/patches/ktexteditor-5.39.0-autotests-dependencies.patch b/gnu/packages/patches/ktexteditor-5.39.0-autotests-dependencies.patch
new file mode 100644
index 0000000000..01a0e572cc
--- /dev/null
+++ b/gnu/packages/patches/ktexteditor-5.39.0-autotests-dependencies.patch
@@ -0,0 +1,49 @@
+Add missing dependencies, see <https://phabricator.kde.org/D8577>.
+
+diff -r -U5 ktexteditor-5.39.0.orig/autotests/CMakeLists.txt ktexteditor-5.39.0/autotests/CMakeLists.txt
+--- ktexteditor-5.39.0.orig/autotests/CMakeLists.txt 2017-10-31 16:28:45.018163060 +0100
++++ ktexteditor-5.39.0/autotests/CMakeLists.txt 2017-10-31 16:28:16.439559888 +0100
+@@ -37,10 +37,11 @@
+ set (KTEXTEDITOR_TEST_LINK_LIBS KF5TextEditor
+ KF5::I18n
+ KF5::IconThemes
+ KF5::GuiAddons
+ Qt5::Qml
++ Qt5::Script
+ )
+
+ include(ECMMarkAsTest)
+
+ # test executable for encoding
+diff -r -U5 ktexteditor-5.39.0.orig/CMakeLists.txt ktexteditor-5.39.0/CMakeLists.txt
+--- ktexteditor-5.39.0.orig/CMakeLists.txt 2017-10-31 16:28:38.578252490 +0100
++++ ktexteditor-5.39.0/CMakeLists.txt 2017-10-31 16:30:24.656778737 +0100
+@@ -38,11 +38,12 @@
+
+ # Dependencies
+ set(REQUIRED_QT_VERSION 5.7.0)
+
+ # Required Qt5 components to build this framework
+-find_package(Qt5 ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Core Widgets Qml PrintSupport Xml XmlPatterns)
++find_package(Qt5 ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Core Widgets Qml
++ Script PrintSupport Xml XmlPatterns)
+
+ find_package(KF5Archive ${KF5_DEP_VERSION} REQUIRED)
+ find_package(KF5Config ${KF5_DEP_VERSION} REQUIRED)
+ find_package(KF5GuiAddons ${KF5_DEP_VERSION} REQUIRED)
+ find_package(KF5I18n ${KF5_DEP_VERSION} REQUIRED)
+diff -r -U5 ktexteditor-5.39.0/autotests/src/vimode/CMakeLists.txt ktexteditor-5.39.0.new/autotests/src/vimode/CMakeLists.txt
+--- ktexteditor-5.39.0/autotests/src/vimode/CMakeLists.txt 1970-01-01 01:00:00.000000000 +0100
++++ ktexteditor-5.39.0.new/autotests/src/vimode/CMakeLists.txt 2017-10-31 16:58:29.909003953 +0100
+@@ -4,10 +4,11 @@
+ ${CMAKE_SOURCE_DIR}/src/vimode
+ )
+
+ set (VIMODE_TEST_LINK_LIBS KF5TextEditor
+ KF5::I18n
++ Qt5::Qml
+ Qt5::Test
+ )
+
+ macro(vimode_unit_test)
+ ecm_add_test(${ARGN} TEST_NAME "vimode_${ARGV0}"