summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-05 05:48:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-05 06:25:24 +0200
commit9859800f5df8827ad7dba6acf32888fa5dc41442 (patch)
tree349f22f3ad862e89ea5171751521d4dbcf521cdc /gnu/packages/patches
parent54c9d7bb69847c89a7193347f858bb4e9476f7df (diff)
gnu: ledger: Update to 3.1.3.
The patch applies but has been unnecessary since 3.1.2. * gnu/packages/finance.scm (ledger): Update to 3.1.3. [source]: Remove obsolete patch. * gnu/packages/patches/ledger-fix-uninitialized.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ledger-fix-uninitialized.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/patches/ledger-fix-uninitialized.patch b/gnu/packages/patches/ledger-fix-uninitialized.patch
deleted file mode 100644
index 128c90ec13..0000000000
--- a/gnu/packages/patches/ledger-fix-uninitialized.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-This fixes failures of tests "BaseLine_opt-datetime-format" and
-"BaseLine_opt-time-report", which were printing an unexpected trailing '*' on
-the last line of output, e.g.:
-
- @@ -5,4 +5,4 @@
- 04/05/13 12:00 PM 04/05/13 01:30 PM 1.50h Lunch
- 04/05/13 11:30 AM 04/05/13 12:00 PM 30.0m Walk
- --------------------------------------------------
- -
- + *
-
-Reported upstream at
-https://groups.google.com/d/msg/ledger-cli/EeJUrUk8YDc/pIR-LOTVEAAJ
-
-diff --git a/src/account.h b/src/account.h
-index 1b97463d..f2555593 100644
---- a/src/account.h
-+++ b/src/account.h
-@@ -187,7 +187,7 @@ public:
-
- datetime_t earliest_checkin;
- datetime_t latest_checkout;
-- bool latest_checkout_cleared;
-+ bool latest_checkout_cleared = false;
-
- std::set<path> filenames;
- std::set<string> accounts_referenced;