summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-01-14 22:24:01 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-14 23:43:49 +0100
commita8b0556ea1e439c89dc1ba33c8864e8b9b811f08 (patch)
treece31fecb8ce254e5b2d0f5255b0637ba8957c973 /gnu/packages/patches
parent152d4076a4b7022c7d8a8a4f78ef93d3780011ce (diff)
gnu: libssh: Update to 0.8.6.
* gnu/packages/patches/libssh-hostname-parser-bug.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/ssh.scm (libssh): Update to 0.8.6. [source](patches): Remove. [arguments]: Add #:phases. (guile-ssh)[source](modules, snippet]: New fields.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/libssh-hostname-parser-bug.patch17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/patches/libssh-hostname-parser-bug.patch b/gnu/packages/patches/libssh-hostname-parser-bug.patch
deleted file mode 100644
index de2336e86d..0000000000
--- a/gnu/packages/patches/libssh-hostname-parser-bug.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-It does not handle the case for the unsupported opcode (-1)
-which would cause a segfault when accessing the "seen" array.
-
-diff --git a/src/config.c b/src/config.c
-index c5313ec8..72e07639 100644
---- a/src/config.c
-+++ b/src/config.c
-@@ -218,7 +218,8 @@ static int ssh_config_parse_line(ssh_session session, const char *line,
- }
-
- opcode = ssh_config_get_opcode(keyword);
-- if (*parsing == 1 && opcode != SOC_HOST) {
-+ if (*parsing == 1 && opcode != SOC_HOST &&
-+ opcode > SOC_UNSUPPORTED && opcode < SOC_END) {
- if (seen[opcode] != 0) {
- return 0;
- }