summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-07 14:15:55 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-12 20:40:55 +0200
commitc60ecc35da9f365f6925da62883d1a01cf9ef3e7 (patch)
treec8e9cc2ce0586714c019d0fc50f7bf449eb5d9b0 /gnu/packages/patches
parent4bc2f9dca3b7b7f0313597c23f1f6434a902e265 (diff)
gnu: glib: Update to 2.54.1.
See <https://bugzilla.gnome.org/show_bug.cgi?id=776504> for the license change. * gnu/packages/patches/glib-respect-datadir.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/glib.scm (glib): Update to 2.54.1. [source](patches): Add 'glib-respect-datadir.patch'. [arguments]<#:phases>: Re-enable timezone test. [license]: Change to LGPL2.1+.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/glib-respect-datadir.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/glib-respect-datadir.patch b/gnu/packages/patches/glib-respect-datadir.patch
new file mode 100644
index 0000000000..309ce9fc0b
--- /dev/null
+++ b/gnu/packages/patches/glib-respect-datadir.patch
@@ -0,0 +1,21 @@
+On Guix, Python modules are in a different output from the executables,
+so searching "../share/glib-2.0" will not work.
+
+This patch restores behaviour prior to this commit:
+<https://git.gnome.org/browse/glib/commit/?id=fe2a9887a8ccb14f2386e01b14834e97a33bc2d7>
+
+--- a/gio/gdbus-2.0/codegen/gdbus-codegen.in
++++ b/gio/gdbus-2.0/codegen/gdbus-codegen.in
+@@ -25,9 +25,12 @@
+
+ srcdir = os.getenv('UNINSTALLED_GLIB_SRCDIR', None)
+ filedir = os.path.dirname(__file__)
++datadir = os.path.join('@datadir@', 'glib-2.0')
+
+ if srcdir is not None:
+ path = os.path.join(srcdir, 'gio', 'gdbus-2.0')
++elif os.path.exists(os.path.join(datadir, 'codegen')):
++ path = datadir
+ elif os.path.basename(filedir) == 'bin':
+ # Make the prefix containing gdbus-codegen 'relocatable' at runtime by
+ # adding /some/prefix/bin/../share/glib-2.0 to the python path