summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-10-31 17:52:04 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-10-31 18:01:00 +0100
commitc94367eaaf1662eca13e0ffac5798318c3f8f3da (patch)
treee3d0c0d228beb3cbba8760f7e086985ec4ee9283 /gnu/packages/patches
parent9c69fec08e286f7486e64c2aa3110fa34974d15d (diff)
gnu: sbcl-geco: Fix build.
* gnu/packages/patches/sbcl-geco-fix-organism-class.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/lisp-xyz.scm (sbcl-geco)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/sbcl-geco-fix-organism-class.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/sbcl-geco-fix-organism-class.patch b/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
new file mode 100644
index 0000000000..817596241e
--- /dev/null
+++ b/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
@@ -0,0 +1,13 @@
+Fix the ORGANISM class so that SBCL >= 2.0.9 can compile it without error.
+
+--- a/classes.lisp 2020-10-28 12:11:10.725659464 +0100
++++ b/classes.lisp 2020-10-31 17:34:36.822752447 +0100
+@@ -148,7 +148,7 @@
+ :accessor score
+ :initarg :score
+ :initform 'nil
+- :type number)
++ :type (or number null))
+ (NORMALIZED-SCORE
+ :accessor normalized-score
+ :initarg :normalized-score