summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2020-09-08 22:28:18 +0200
committerAndreas Enge <andreas@enge.fr>2020-09-08 22:29:32 +0200
commitee7a7c9014f7dd238ab42d15ef3f5f1fe187d1c3 (patch)
tree0e7c2279883eb4a4064b4161dd79b6ce10592c21 /gnu/packages/patches
parent44de399151c49fdf512e092ffd37ee25d08280be (diff)
genimage: Add patch needed for the test on ARM architectures.
* gnu/packages/patches/genimage-signedness.patch: New file. * gnu/packages/genimage.scm (genimage)[source]: Add patch. * gnu/local.mk (dist_patch_DATA): Register patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/genimage-signedness.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/genimage-signedness.patch b/gnu/packages/patches/genimage-signedness.patch
new file mode 100644
index 0000000000..2204dfb545
--- /dev/null
+++ b/gnu/packages/patches/genimage-signedness.patch
@@ -0,0 +1,24 @@
+commit 6574665f9d6c0757e8f55ccb465afbcaa90bf019
+Author: Timotej Lazar <timotej.lazar@araneo.si>
+Date: Wed Aug 19 19:36:02 2020 +0200
+
+ test: normalize flags reported by dumpe2fs
+
+ Filesystem flags depend on the system – usually signed_directory_hash,
+ but unsigned_directory_hash at least on arm64.
+
+ Signed-off-by: Timotej Lazar <timotej.lazar@araneo.si>
+
+diff --git a/test/basic-images.test b/test/basic-images.test
+index f6685e1..cb104c3 100755
+--- a/test/basic-images.test
++++ b/test/basic-images.test
+@@ -158,6 +158,8 @@ check_ext() {
+ # format change
+ csum2="Group 0: (Blocks 1-4095) \\[ITABLE_ZEROED\\]\| Checksum .*, unused inodes 205"
+ dumpe2fs "${1}" | grep -v "^\($uuid\|$seed\|$csum1\|$csum2\)" > "dump" &&
++ # some architectures (including arm64) use unsigned char
++ sed -i 's/un\(signed_directory_hash\)/\1/' "dump" &&
+ # fixup for ext3 journal size with old tune2fs
+ sed -i 's/^\(Journal size: \)1029k$/\11024k/' "dump" &&
+ # output format changed with some version