summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-28 14:01:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-28 20:19:28 +0100
commit01307bba9c00ada07f8a39bd8de7031beef12afd (patch)
tree5b077642f24ae2daeb22bc8c4f22936ca5c2abf2 /gnu/packages/patches
parent6da31b3c7bfcd8f012695574e91d7da32f202280 (diff)
gnu: reptyr: Update to 0.7.0.
* gnu/packages/screen.scm (reptyr): Update to 0.7.0. [source]: Remove patch. [arguments]: Add bash completion directory name. * gnu/packages/patches/reptyr-fix-gcc-7.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/reptyr-fix-gcc-7.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/patches/reptyr-fix-gcc-7.patch b/gnu/packages/patches/reptyr-fix-gcc-7.patch
deleted file mode 100644
index 5e0e581218..0000000000
--- a/gnu/packages/patches/reptyr-fix-gcc-7.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-This patch allows reptyr to build with gcc 7. It is taken from reptyr mainline patches
-fa0d63f and b45fd92.
-
-https://github.com/nelhage/reptyr/commit/fa0d63ff8c488be15976e5353580b565e85586a1
-https://github.com/nelhage/reptyr/commit/b45fd9238958fcf2d8f3d6fc23e6d491febea2ac
-
-Patch by Nelson Elhage <nelhage@nelhage.com>.
-
-diff --git a/attach.c b/attach.c
-index bd8ef8c..8d9cbf8 100644
---- a/attach.c
-+++ b/attach.c
-@@ -389,8 +389,11 @@ int setup_steal_socket(struct steal_pty_state *steal) {
- return errno;
-
- steal->addr_un.sun_family = AF_UNIX;
-- snprintf(steal->addr_un.sun_path, sizeof(steal->addr_un.sun_path),
-- "%s/reptyr.sock", steal->tmpdir);
-+ if (snprintf(steal->addr_un.sun_path, sizeof(steal->addr_un.sun_path),
-+ "%s/reptyr.sock", steal->tmpdir) >= sizeof(steal->addr_un.sun_path)) {
-+ error("tmpdir path too long!");
-+ return ENAMETOOLONG;
-+ }
-
- if ((steal->sockfd = socket(AF_UNIX, SOCK_DGRAM, 0)) < 0)
- return errno;
-diff --git a/platform/linux/linux.h b/platform/linux/linux.h
-index 9e6b78a..3ec5a99 100644
---- a/platform/linux/linux.h
-+++ b/platform/linux/linux.h
-@@ -40,6 +40,7 @@
- #include <sys/ptrace.h>
- #include <asm/ptrace.h>
- #include <sys/types.h>
-+#include <sys/sysmacros.h>
- #include <sys/user.h>
- #include <unistd.h>
- #include <stdlib.h>