summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-10-07 09:32:34 +0200
committerMarius Bakke <marius@gnu.org>2020-10-13 23:36:43 +0200
commit331aaf52806b27430c4efaf8f230097ede69e61a (patch)
treed00e091c1719bb27d0bb12762511bc1e93a794a7 /gnu/packages/patches
parent3182d629a25b1132fc542391b451580d44d9f92c (diff)
gnu: python-chardet: Enable tests.
* gnu/packages/python-xyz.scm (python-chardet) [source]: Add upstream patch. [arguments]: Remove. * gnu/packages/patches/python-chardet-3.0.4-pytest.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-chardet-3.0.4-pytest.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-chardet-3.0.4-pytest.patch b/gnu/packages/patches/python-chardet-3.0.4-pytest.patch
new file mode 100644
index 0000000000..d5bf7ccc28
--- /dev/null
+++ b/gnu/packages/patches/python-chardet-3.0.4-pytest.patch
@@ -0,0 +1,15 @@
+Fix test failure with Pytest 4.
+
+Taken from upstream:
+https://github.com/chardet/chardet/commit/440828f8faafdb58700c64a9ea8f6a30b154c08b
+
+diff --git a/test.py b/test.py
+--- a/test.py
++++ b/test.py
+@@ -59,5 +59,5 @@ def gen_test_params():
+ full_path = join(path, file_name)
+ test_case = full_path, encoding
+ if full_path in EXPECTED_FAILURES:
+- test_case = pytest.mark.xfail(test_case)
++ test_case = pytest.param(*test_case, marks=pytest.mark.xfail)
+ yield test_case