summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-05 02:20:35 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-16 23:20:20 +0100
commit40d2bddd01dd054e68aadc98f77380a8b9977f3c (patch)
tree02d5bb971c3ab709b7826e112488ca19d7949512 /gnu/packages/patches
parent9e016129e16962d4f751d934fdc0fbd6c6d64ef8 (diff)
gnu: Add xmoto.
* gnu/packages/games.scm (xmoto): New variable. * gnu/packages/patches/xmoto-remove-glext.patch: New file. * gnu/packages/patches/xmoto-reproducible.patch: New file. * gnu/packages/patches/xmoto-utf8.patch: New file. * gnu/local.mk (dist_patch_DATA): Reference new files.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/xmoto-remove-glext.patch23
-rw-r--r--gnu/packages/patches/xmoto-reproducible.patch24
-rw-r--r--gnu/packages/patches/xmoto-utf8.patch16
3 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/patches/xmoto-remove-glext.patch b/gnu/packages/patches/xmoto-remove-glext.patch
new file mode 100644
index 0000000000..ad0c848d1d
--- /dev/null
+++ b/gnu/packages/patches/xmoto-remove-glext.patch
@@ -0,0 +1,23 @@
+Description: Allow building without upstream-supplied glext.h
+Author: Stephen Kitt <steve@sk2.org>
+Bug: http://todo.xmoto.tuxfamily.org/index.php?do=details&task_id=803
+
+--- xmoto-0.5.9+dfsg.orig/src/include/xm_OpenGL.h
++++ xmoto-0.5.9+dfsg/src/include/xm_OpenGL.h
+@@ -1,7 +1,6 @@
+ #ifdef ENABLE_OPENGL
+ /* Pull in OpenGL headers */
+ /* following scissored from SDL_opengl.h */
+-#define __glext_h_ /* Don't let gl.h include glext.h */
+ #ifdef HAVE_APPLE_OPENGL_FRAMEWORK
+ #include <OpenGL/gl.h> /* Header File For The OpenGL Library */
+ #include <OpenGL/glu.h> /* Header File For The GLU Library */
+@@ -12,8 +11,5 @@
+ #include <GL/gl.h> /* Header File For The OpenGL Library */
+ #include <GL/glu.h> /* Header File For The GLU Library */
+ #endif
+-#undef __glext_h_
+-
+-#include "../glext.h"
+
+ #endif
diff --git a/gnu/packages/patches/xmoto-reproducible.patch b/gnu/packages/patches/xmoto-reproducible.patch
new file mode 100644
index 0000000000..606f4ec714
--- /dev/null
+++ b/gnu/packages/patches/xmoto-reproducible.patch
@@ -0,0 +1,24 @@
+Description: Avoid __DATE__ and __TIME__ to build reproducibly
+Author: Stephen Kitt <skitt@debian.org>
+
+--- a/src/GameInit.cpp
++++ b/src/GameInit.cpp
+@@ -248,7 +248,6 @@
+ Logger::setActiv(XMSession::instance()->noLog() == false); /* apply log activ mode */
+
+ LogInfo(std::string("X-Moto " + XMBuild::getVersionString(true)).c_str());
+- LogInfo("compiled at "__DATE__" "__TIME__);
+ if(SwapEndian::bigendien) {
+ LogInfo("Systeme is bigendien");
+ } else {
+--- a/src/states/StateOptions.cpp
++++ b/src/states/StateOptions.cpp
+@@ -1233,8 +1233,6 @@
+ int p=25;
+ makeWindowOptions_infos_line(v_window, "Version", "X-Moto " + XMBuild::getVersionString(true), p);
+ p+=20;
+- makeWindowOptions_infos_line(v_window, "Compilation date", __DATE__ " " __TIME__, p);
+- p+=20;
+ makeWindowOptions_infos_line(v_window, "User data directory", XMFS::getUserDir(FDT_DATA), p);
+ p+=20;
+ makeWindowOptions_infos_line(v_window, "User config directory", XMFS::getUserDir(FDT_CONFIG), p);
diff --git a/gnu/packages/patches/xmoto-utf8.patch b/gnu/packages/patches/xmoto-utf8.patch
new file mode 100644
index 0000000000..e5d0dfb2a4
--- /dev/null
+++ b/gnu/packages/patches/xmoto-utf8.patch
@@ -0,0 +1,16 @@
+Description: Build with g++'s new utf8.h
+Author: Stephen Kitt <skitt@debian.org>
+
+--- a/src/helpers/utf8.h
++++ b/src/helpers/utf8.h
+@@ -18,8 +18,8 @@
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ =============================================================================*/
+
+-#ifndef __UTF8_H__
+-#define __UTF8_H__
++#ifndef __XMOTO_UTF8_H__
++#define __XMOTO_UTF8_H__
+
+ #include <vector>
+ #include <string>