summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-16 09:31:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-16 09:31:54 +0300
commit4a822462ef66c4c61d2f3351cc2d91dd76e1a701 (patch)
treeb524e51045e779810fcdcc82a199d4aad53f3c07 /gnu/packages/patches
parent9eb6d7125bc122aed1faff21ac7aa4a04e55ff74 (diff)
Revert "gnu: aspell: Update to 0.60.8."
This reverts commit 4fcb6a3558b4212462c7c2afd2f5a834342f41be. aspell causes about 1400 packages to be rebuilt.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/aspell-gcc-compat.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/aspell-gcc-compat.patch b/gnu/packages/patches/aspell-gcc-compat.patch
new file mode 100644
index 0000000000..94c44f8fb6
--- /dev/null
+++ b/gnu/packages/patches/aspell-gcc-compat.patch
@@ -0,0 +1,31 @@
+Fix GCC7 warnings.
+
+Taken from upstream:
+https://git.savannah.gnu.org/cgit/aspell.git/commit/?id=8089fa02122fed0a6394eba14bbedcb1d18e2384
+
+diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
+index a979539..19ab63c 100644
+--- a/modules/filter/tex.cpp
++++ b/modules/filter/tex.cpp
+@@ -174,7 +174,7 @@ namespace {
+
+ if (c == '{') {
+
+- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
++ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
+ push_command(Parm);
+
+ top.in_what = Parm;
+diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
+index db54f3d..89ee09d 100644
+--- a/prog/check_funs.cpp
++++ b/prog/check_funs.cpp
+@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
+ }
+ }
+ if (i == width-1) {
+- if (word == '\0')
++ if (*word == '\0')
+ put(out,' ');
+ else if (word[len] == '\0')
+ put(out, word, len);