summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-03 18:28:56 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-23 07:46:27 -0500
commita2e7e95663d11a1059fa900b4640e8ab75df627f (patch)
treef59909873ab3f1729e4e5682a47b82d6ede43976 /gnu/packages/patches
parent7c8ea31ac94f5b55f2f4bbc16264b987cb9556e3 (diff)
gnu: gnucash: Disable the stress-options-test using a phase.
The qof test is also reinstated; it was failing because the needed locales were not installed. * gnu/packages/patches/gnucash-disable-failing-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Unregister it. * gnu/packages/gnucash.scm (gnucash)[patches]: Remove it. [phases]{disable-stress-options-test}: Implement it using SUBSTITUTES*. {install-locales}: New phase.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gnucash-disable-failing-tests.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/gnu/packages/patches/gnucash-disable-failing-tests.patch b/gnu/packages/patches/gnucash-disable-failing-tests.patch
deleted file mode 100644
index e0fdd86b5d..0000000000
--- a/gnu/packages/patches/gnucash-disable-failing-tests.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-test-stress-options.scm does not exist, and test-qof passes when run in the
-build directory after the gnucash build.
-
-diff -ur gnucash-3.3.old/gnucash/report/standard-reports/test/CMakeLists.txt gnucash-3.3/gnucash/report/standard-reports/test/CMakeLists.txt
---- gnucash-3.3.old/gnucash/report/standard-reports/test/CMakeLists.txt 2018-10-04 09:29:00.916641417 -0400
-+++ gnucash-3.3/gnucash/report/standard-reports/test/CMakeLists.txt 2018-10-04 09:30:52.962504860 -0400
-@@ -13,10 +13,6 @@
- test-income-gst.scm
- )
-
--set(scm_test_with_textual_ports_SOURCES
-- test-stress-options.scm
--)
--
- set(GUILE_DEPENDS
- scm-gnc-module
- scm-app-utils
-@@ -31,9 +27,6 @@
-
- if (HAVE_SRFI64)
- gnc_add_scheme_tests("${scm_test_with_srfi64_SOURCES}")
-- if (HAVE_TEXT_PORTS)
-- gnc_add_scheme_tests("${scm_test_with_textual_ports_SOURCES}")
-- endif (HAVE_TEXT_PORTS)
- endif (HAVE_SRFI64)
-
- gnc_add_scheme_tests("${scm_test_standard_reports_SOURCES}")
-diff -ur gnucash-3.3.old/libgnucash/engine/test/CMakeLists.txt gnucash-3.3/libgnucash/engine/test/CMakeLists.txt
---- gnucash-3.3.old/libgnucash/engine/test/CMakeLists.txt 2018-10-04 09:29:00.876640751 -0400
-+++ gnucash-3.3/libgnucash/engine/test/CMakeLists.txt 2018-10-05 10:46:22.542962546 -0400
-@@ -54,8 +54,6 @@
- # This test does not run on Win32
- if (NOT WIN32)
- set(SOURCES ${test_qof_SOURCES} ${CMAKE_SOURCE_DIR}/common/test-core/unittest-support.c)
-- add_engine_test(test-qof "${SOURCES}")
-- target_compile_definitions(test-qof PRIVATE TESTPROG=test_qof)
-
- set(SOURCES ${test_engine_SOURCES} ${CMAKE_SOURCE_DIR}/common/test-core/unittest-support.c)
- add_engine_test(test-engine "${SOURCES}")