summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-06 16:00:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-06 16:32:31 +0100
commit350b7f8a7441d7df89249b356299a843b9a18794 (patch)
treee565d0d55f7ac6ee01208a4bfda0edd64c44cf14 /gnu/packages/patches
parentf339df425eb00cb8d9418b3a338d7e03afd4a09c (diff)
gnu: valgrind: Update to 3.14.0.
* gnu/packages/patches/valgrind-glibc-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/valgrind.scm (valgrind): Update to 3.14.0. [supported-systems]: Add mips64el-linux.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/valgrind-glibc-compat.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/valgrind-glibc-compat.patch b/gnu/packages/patches/valgrind-glibc-compat.patch
deleted file mode 100644
index 4f8effd207..0000000000
--- a/gnu/packages/patches/valgrind-glibc-compat.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Fix build failure with glibc 2.26.
-
-Patch copied from upstream source repository:
-https://sourceware.org/git/?p=valgrind.git;a=commit;h=2b5eab6a8db1b0487a3ad7fc4e7eeda6d3513626
-
-diff --git a/memcheck/tests/linux/stack_changes.c b/memcheck/tests/linux/stack_changes.c
-index a978fc2..7f97b90 100644
---- a/memcheck/tests/linux/stack_changes.c
-+++ b/memcheck/tests/linux/stack_changes.c
-@@ -10,7 +10,7 @@
- // This test is checking the libc context calls (setcontext, etc.) and
- // checks that Valgrind notices their stack changes properly.
-
--typedef struct ucontext mycontext;
-+typedef ucontext_t mycontext;
-
- mycontext ctx1, ctx2, oldc;
- int count;