summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-24 21:25:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-24 21:25:52 +0100
commitaa51eb2073f17e40d660d0beaeb7b1b78aa9e1cc (patch)
tree5ccb7f83712c4400176a344e537b5fcbbb7047aa /gnu/packages/patches
parent1b9eb93a5dd1e90291b614311cd1fb2051e72718 (diff)
parent6eb35d4a780d37b809a6c8c1794ff227da2fa29d (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ath9k-htc-firmware-gcc.patch10
-rw-r--r--gnu/packages/patches/clamav-system-tomsfastmath.patch76
-rw-r--r--gnu/packages/patches/libtommath-fix-linkage.patch55
3 files changed, 98 insertions, 43 deletions
diff --git a/gnu/packages/patches/ath9k-htc-firmware-gcc.patch b/gnu/packages/patches/ath9k-htc-firmware-gcc.patch
index 79924ca8cb..5e912f6f5c 100644
--- a/gnu/packages/patches/ath9k-htc-firmware-gcc.patch
+++ b/gnu/packages/patches/ath9k-htc-firmware-gcc.patch
@@ -16,16 +16,6 @@ diff --git a/include/xtensa-config.h b/include/xtensa-config.h
index 30f4f41..fe9b051 100644
--- a/include/xtensa-config.h
+++ b/include/xtensa-config.h
-@@ -1,7 +1,7 @@
- /* Xtensa configuration settings.
-- Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2010
-+ Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007
- Free Software Foundation, Inc.
-- Contributed by Bob Wilson (bob.wilson@acm.org) at Tensilica.
-+ Contributed by Bob Wilson (bwilson@tensilica.com) at Tensilica.
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
@@ -44,10 +44,7 @@
#define XCHAL_HAVE_L32R 1
diff --git a/gnu/packages/patches/clamav-system-tomsfastmath.patch b/gnu/packages/patches/clamav-system-tomsfastmath.patch
index 07ab79f3f7..2153723a76 100644
--- a/gnu/packages/patches/clamav-system-tomsfastmath.patch
+++ b/gnu/packages/patches/clamav-system-tomsfastmath.patch
@@ -1,3 +1,9 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Sun, 24 Feb 2019 15:50:37 +0100
+Subject: gnu: clamav: Add support for system tomsfastmath.
+
+Adjusted from the original for clamav 0.101.1:
+
From 756ff89526b5ffaa7a4f49b1bbecf2ecbd6f85f9 Mon Sep 17 00:00:00 2001
From: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
Date: Wed, 11 Mar 2015 20:03:15 +0100
@@ -13,17 +19,17 @@ Patch-Name: add-support-for-system-tomsfastmath.patch
5 files changed, 28 insertions(+), 4 deletions(-)
create mode 100644 m4/reorganization/libs/tomsfastmath.m4
---- a/configure.ac
-+++ b/configure.ac
-@@ -82,6 +82,7 @@ m4_include([m4/reorganization/libs/xml.m
- m4_include([m4/reorganization/libs/openssl.m4])
+--- a/configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ b/configure.ac 2019-02-24 15:47:14.076992864 +0100
+@@ -89,6 +89,7 @@
m4_include([m4/reorganization/libs/json.m4])
m4_include([m4/reorganization/libs/pcre.m4])
+ m4_include([m4/reorganization/libs/libmspack.m4])
+m4_include([m4/reorganization/libs/tomsfastmath.m4])
- AM_MAINTAINER_MODE
- m4_include([m4/reorganization/libs/libz.m4])
-@@ -285,6 +286,7 @@ else
+ if test "x$use_internal_mspack" = "xno"; then
+ mspack_msg="External, $LIBMSPACK_CFLAGS $LIBMSPACK_LIBS"
+@@ -297,6 +298,7 @@
fi
CL_MSG_STATUS([yara ],[$enable_yara],[$enable_yara])
CL_MSG_STATUS([fts ],[yes],[$lfs_fts_msg])
@@ -31,9 +37,28 @@ Patch-Name: add-support-for-system-tomsfastmath.patch
# Yep, downgrading the compiler avoids the bug too:
---- a/libclamav/Makefile.am
-+++ b/libclamav/Makefile.am
-@@ -496,8 +496,10 @@ libclamav_la_SOURCES += yara_arena.c \
+diff -Naur clamav-0.101.1/libclamav/bignum.h clamav-0.101.1b/libclamav/bignum.h
+--- a/libclamav/bignum.h 1970-01-01 01:00:00.000000000 +0100
++++ b/libclamav/bignum.h 2019-02-24 15:46:36.216998323 +0100
+@@ -1,9 +1,13 @@
+ #ifndef BIGNUM_H_
+ #define BIGNUM_H_
+
++#if HAVE_SYSTEM_TOMSFASTMATH
++#include <tfm.h>
++#else
+ #define TFM_CHECK
+-
+ #include "bignum_fast.h"
++#endif
++
+ typedef fp_int mp_int;
+ #define mp_cmp fp_cmp
+ #define mp_toradix_n(a,b,c,d) fp_toradix_n(a,b,c,d)
+diff -Naur clamav-0.101.1/libclamav/Makefile.am clamav-0.101.1b/libclamav/Makefile.am
+--- a/libclamav/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ b/libclamav/Makefile.am 2019-02-24 15:46:36.216998323 +0100
+@@ -597,8 +597,10 @@
yara_clam.h
endif
@@ -46,7 +71,7 @@ Patch-Name: add-support-for-system-tomsfastmath.patch
tomsfastmath/addsub/fp_add.c\
tomsfastmath/addsub/fp_add_d.c\
tomsfastmath/addsub/fp_addmod.c\
-@@ -579,6 +581,10 @@ libclamav_la_SOURCES += bignum.h\
+@@ -680,6 +682,10 @@
tomsfastmath/sqr/fp_sqr_comba_generic.c\
tomsfastmath/sqr/fp_sqr_comba_small_set.c\
tomsfastmath/sqr/fp_sqrmod.c
@@ -57,26 +82,10 @@ Patch-Name: add-support-for-system-tomsfastmath.patch
.PHONY: version.h.tmp
version.c: version.h
---- a/libclamav/bignum.h
-+++ b/libclamav/bignum.h
-@@ -1,9 +1,13 @@
- #ifndef BIGNUM_H_
- #define BIGNUM_H_
-
-+#if HAVE_SYSTEM_TOMSFASTMATH
-+#include <tfm.h>
-+#else
- #define TFM_CHECK
--
- #include "bignum_fast.h"
-+#endif
-+
- typedef fp_int mp_int;
- #define mp_cmp fp_cmp
- #define mp_toradix_n(a,b,c,d) fp_toradix_n(a,b,c,d)
---- a/libclamav/xdp.c
-+++ b/libclamav/xdp.c
-@@ -57,7 +57,7 @@
+diff -Naur clamav-0.101.1/libclamav/xdp.c clamav-0.101.1b/libclamav/xdp.c
+--- a/libclamav/xdp.c 1970-01-01 01:00:00.000000000 +0100
++++ b/libclamav/xdp.c 2019-02-24 15:46:36.216998323 +0100
+@@ -52,7 +52,7 @@
#include "scanners.h"
#include "conv.h"
#include "xdp.h"
@@ -85,8 +94,9 @@ Patch-Name: add-support-for-system-tomsfastmath.patch
#include "filetypes.h"
static char *dump_xdp(cli_ctx *ctx, const char *start, size_t sz);
---- /dev/null
-+++ b/m4/reorganization/libs/tomsfastmath.m4
+diff -Naur clamav-0.101.1/m4/reorganization/libs/tomsfastmath.m4 clamav-0.101.1b/m4/reorganization/libs/tomsfastmath.m4
+--- a/m4/reorganization/libs/tomsfastmath.m4 1970-01-01 01:00:00.000000000 +0100
++++ b/m4/reorganization/libs/tomsfastmath.m4 2019-02-24 15:46:36.216998323 +0100
@@ -0,0 +1,12 @@
+dnl Check for system tomsfastmath
+PKG_CHECK_MODULES([TOMSFASTMATH], [tomsfastmath], [have_system_tomsfastmath=yes], [have_system_tomsfastmath=no])
diff --git a/gnu/packages/patches/libtommath-fix-linkage.patch b/gnu/packages/patches/libtommath-fix-linkage.patch
new file mode 100644
index 0000000000..1a9d46eb7c
--- /dev/null
+++ b/gnu/packages/patches/libtommath-fix-linkage.patch
@@ -0,0 +1,55 @@
+https://github.com/libtom/libtommath/commit/93dea3a4162527346cd8856bfda6f17ffe98ab04.patch
+
+From 93dea3a4162527346cd8856bfda6f17ffe98ab04 Mon Sep 17 00:00:00 2001
+From: Steffen Jaeckel <s@jaeckel.eu>
+Date: Thu, 31 Jan 2019 14:12:03 +0100
+Subject: [PATCH] makefile.shared: fix compilation and linkage
+
+---
+ makefile.shared | 15 ++++++++-------
+ 1 file changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/makefile.shared b/makefile.shared
+index 3955f830..870b18d1 100644
+--- a/makefile.shared
++++ b/makefile.shared
+@@ -18,6 +18,7 @@ ifndef LIBTOOL
+ endif
+ endif
+ LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC)
++LTLINK = $(LIBTOOL) --mode=link --tag=CC $(CC)
+
+ LCOV_ARGS=--directory .libs --directory .
+
+@@ -59,7 +60,7 @@ objs: $(OBJECTS)
+ LOBJECTS = $(OBJECTS:.o=.lo)
+
+ $(LIBNAME): $(OBJECTS)
+- $(LIBTOOL) --mode=link --tag=CC $(CC) $(LDFLAGS) $(LOBJECTS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_SO) $(LIBTOOLFLAGS)
++ $(LTLINK) $(LDFLAGS) $(LOBJECTS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_SO) $(LIBTOOLFLAGS)
+
+ install: $(LIBNAME)
+ install -d $(DESTDIR)$(LIBPATH)
+@@ -76,16 +77,16 @@ uninstall:
+ rm $(DESTDIR)$(LIBPATH)/pkgconfig/libtommath.pc
+
+ test: $(LIBNAME) demo/demo.o
+- $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
+- $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
++ $(LTCOMPILE) $(CFLAGS) -c demo/demo.c -o demo/demo.o
++ $(LTLINK) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
+
+ test_standalone: $(LIBNAME) demo/demo.o
+- $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
+- $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
++ $(LTCOMPILE) $(CFLAGS) -c demo/demo.c -o demo/demo.o
++ $(LTLINK) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
+
+ .PHONY: mtest
+ mtest:
+- cd mtest ; $(CC) $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
++ cd mtest ; $(CC) $(CFLAGS) -O0 mtest.c $(LDFLAGS) -o mtest
+
+ timing: $(LIBNAME) demo/timing.c
+- $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o timing
++ $(LTLINK) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o timing