summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-27 17:52:48 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-27 17:58:43 +0200
commit244d4f48770ac3e8cac4da435ff6cf8a5a8e14b4 (patch)
tree1d8384f7cef37a3db2351c65e4a0c0fa54eaa679 /gnu/packages/patches
parentdecb4c26fa1c748b118e33495d5493d84a6ca6c9 (diff)
gnu: serf: Update to 1.3.9.
* gnu/packages/patches/serf-comment-style-fix.patch, gnu/packages/patches/serf-deflate-buckets-test-fix.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/web.scm (serf): Update to 1.3.9. [source]: Remove patches.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/serf-comment-style-fix.patch23
-rw-r--r--gnu/packages/patches/serf-deflate-buckets-test-fix.patch69
2 files changed, 0 insertions, 92 deletions
diff --git a/gnu/packages/patches/serf-comment-style-fix.patch b/gnu/packages/patches/serf-comment-style-fix.patch
deleted file mode 100644
index 5d336fb3c8..0000000000
--- a/gnu/packages/patches/serf-comment-style-fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-r2443 | andreas.stieger@gmx.de | 2014-10-21 17:42:56 -0400 (Tue, 21 Oct 2014) | 7 lines
-
-Follow-up to r2419: Correct comment style
-
-* test/test_buckets.c
- (deflate_compress): Correct comment style not supported by strict
- compilers, fails on /branches/1.3.x
-
-Index: test/test_buckets.c
-===================================================================
---- test/test_buckets.c (revision 2442)
-+++ test/test_buckets.c (revision 2443)
-@@ -1323,9 +1323,9 @@
-
- /* The largest buffer we should need is 0.1% larger than the
- uncompressed data, + 12 bytes. This info comes from zlib.h.
-+ buf_size = orig_len + (orig_len / 1000) + 12;
- Note: This isn't sufficient when using Z_NO_FLUSH and extremely compressed
- data. Use a buffer bigger than what we need. */
--// buf_size = orig_len + (orig_len / 1000) + 12;
- buf_size = 100000;
-
- write_buf = apr_palloc(pool, buf_size);
diff --git a/gnu/packages/patches/serf-deflate-buckets-test-fix.patch b/gnu/packages/patches/serf-deflate-buckets-test-fix.patch
deleted file mode 100644
index be8be1b1e8..0000000000
--- a/gnu/packages/patches/serf-deflate-buckets-test-fix.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-r2445 | chemodax | 2014-10-23 12:15:22 -0400 (Thu, 23 Oct 2014) | 6 lines
-
-Reduce memory usage by deflate buckets test.
-
-* test/test_buckets.c
- (deflate_buckets): Add POOL argument and use it instead of tb->pool.
- (test_deflate_buckets): Use iterpool for deflate_buckets() call.
-
-Index: test/test_buckets.c
-===================================================================
---- test/test_buckets.c (revision 2444)
-+++ test/test_buckets.c (revision 2445)
-@@ -1400,12 +1400,12 @@
- expected_len);
- }
-
--static void deflate_buckets(CuTest *tc, int nr_of_loops)
-+static void deflate_buckets(CuTest *tc, int nr_of_loops, apr_pool_t *pool)
- {
- const char *msg = "12345678901234567890123456789012345678901234567890";
-
- test_baton_t *tb = tc->testBaton;
-- serf_bucket_alloc_t *alloc = serf_bucket_allocator_create(tb->pool, NULL,
-+ serf_bucket_alloc_t *alloc = serf_bucket_allocator_create(pool, NULL,
- NULL);
- z_stream zdestr;
- int i;
-@@ -1424,8 +1424,8 @@
- {
- serf_config_t *config;
-
-- serf_context_t *ctx = serf_context_create(tb->pool);
-- /* status = */ serf__config_store_get_config(ctx, NULL, &config, tb->pool);
-+ serf_context_t *ctx = serf_context_create(pool);
-+ /* status = */ serf__config_store_get_config(ctx, NULL, &config, pool);
-
- serf_bucket_set_config(defbkt, config);
- }
-@@ -1447,11 +1447,11 @@
- if (i == nr_of_loops - 1) {
- CuAssertIntEquals(tc, APR_SUCCESS,
- deflate_compress(&data, &len, &zdestr, msg,
-- strlen(msg), 1, tb->pool));
-+ strlen(msg), 1, pool));
- } else {
- CuAssertIntEquals(tc, APR_SUCCESS,
- deflate_compress(&data, &len, &zdestr, msg,
-- strlen(msg), 0, tb->pool));
-+ strlen(msg), 0, pool));
- }
-
- if (len == 0)
-@@ -1469,10 +1469,15 @@
- static void test_deflate_buckets(CuTest *tc)
- {
- int i;
-+ apr_pool_t *iterpool;
-+ test_baton_t *tb = tc->testBaton;
-
-+ apr_pool_create(&iterpool, tb->pool);
- for (i = 1; i < 1000; i++) {
-- deflate_buckets(tc, i);
-+ apr_pool_clear(iterpool);
-+ deflate_buckets(tc, i, iterpool);
- }
-+ apr_pool_destroy(iterpool);
- }
-
- static apr_status_t discard_data(serf_bucket_t *bkt,