summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-11-17 18:30:50 +0100
committerAndreas Enge <andreas@enge.fr>2013-11-18 21:12:27 +0100
commitf39298004162b94447a301d582e3f73892c99953 (patch)
treed1bc93e8b5cb0ddb326c07ebca1b0d7748079a7f /gnu/packages/patches
parentc42a4b76c400fd8cf30e145061637c70a2b12a02 (diff)
gnu: pspp: Add input cairo.
* gnu/packages/maths.scm (pspp): Add cairo and further necessary inputs. * gnu/packages/patches/pspp-tests.patch: New file, thanks to John Darrington <john@darrington.wattle.id.au>. * gnu-system.am (dist_patch_DATA): Register patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/pspp-tests.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/pspp-tests.patch b/gnu/packages/patches/pspp-tests.patch
new file mode 100644
index 0000000000..3e61b68804
--- /dev/null
+++ b/gnu/packages/patches/pspp-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/output/render-test.c b/tests/output/render-test.c
+index 5f4c1da..e9df96c 100644
+--- a/tests/output/render-test.c
++++ b/tests/output/render-test.c
+@@ -142,7 +142,7 @@ configure_drivers (int width, int length)
+ string_map_insert (&options, "left-margin", "0");
+ string_map_insert (&options, "right-margin", "0");
+ string_map_insert_nocopy (&options, xstrdup ("paper-size"),
+- xasprintf ("%dx%dpt", width * 5, length * 8));
++ xasprintf ("%dx%dpt", width * 5, length * 16));
+ driver = output_driver_create (&options);
+ if (driver == NULL)
+ exit (EXIT_FAILURE);