summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-19 18:12:34 -0400
committerMark H Weaver <mhw@netris.org>2015-07-19 18:12:34 -0400
commit1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f (patch)
tree4b650999e49a6f4d3dd116fab3f9ee8222247e07 /gnu/packages/patches
parentaa27987f71cb8afa698ede551e20b1248f160113 (diff)
parent50c7a1e297bff0935674b4f30e854a8889becfdd (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/crda-optional-gcrypt.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/crda-optional-gcrypt.patch b/gnu/packages/patches/crda-optional-gcrypt.patch
new file mode 100644
index 0000000000..770ab1a97e
--- /dev/null
+++ b/gnu/packages/patches/crda-optional-gcrypt.patch
@@ -0,0 +1,20 @@
+This patch allows us to make the libgcrypt dependency optional (which it
+is, if you look at the code), which in turns allows us to build CRDA
+without the signature-checking capability on 'regulatory.bin'.
+
+--- crda/Makefile 2015-07-17 11:33:33.546712893 +0200
++++ crda/Makefile 2015-07-17 11:34:05.210994373 +0200
+@@ -45,12 +45,14 @@ LDLIBS += `pkg-config --libs openssl`
+ $(LIBREG): keys-ssl.c
+
+ else
++ifeq ($(USE_GCRYPT),1)
+ CFLAGS += -DUSE_GCRYPT
+ LDLIBS += -lgcrypt
+
+ $(LIBREG): keys-gcrypt.c
+
+ endif
++endif
+ MKDIR ?= mkdir -p
+ INSTALL ?= install