summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-16 15:31:41 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-16 17:59:16 +0200
commit2ed74cea5c1a353e7634f7e1be8bcc27fcac6ede (patch)
tree7895714cd78187eb3e7b2312fddaa4a7358ca185 /gnu/packages/patches
parent1d6c8db57cbcd26994e3c6f0b4662bd783166bbf (diff)
gnu: imagemagick: Update to 6.9.2-1.
* gnu/packages/imagemagick.scm (imagemagick): Update to 6.9.2-1. [source]: Add imagemagick-test-segv.patch. [inputs]: Replace LIBJPEG-8 with LIBJPEG.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/imagemagick-test-segv.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/imagemagick-test-segv.patch b/gnu/packages/patches/imagemagick-test-segv.patch
new file mode 100644
index 0000000000..6626e54828
--- /dev/null
+++ b/gnu/packages/patches/imagemagick-test-segv.patch
@@ -0,0 +1,20 @@
+This patch works around a segmentation fault in 'Magick++/tests/color' when
+running 'Magick++/tests/tests.tap'. Here we get an exception early on, which
+is supposedly harmless:
+
+ Caught exception: color: UnableToOpenConfigureFile `colors.xml' @ warning/configure.c/GetConfigureOptions/706
+
+However, when the stack unwinders run, 'UnregisterDOTImage' gets called even
+though 'RegisterDOTImage' hadn't been called yet; thus, 'graphic_context' in
+coders/dot.c is NULL, leading to the segfault.
+
+--- ImageMagick-6.9.2-1/coders/dot.c 2015-09-16 17:32:42.900323334 +0200
++++ ImageMagick-6.9.2-1/coders/dot.c 2015-09-16 17:32:48.312367636 +0200
+@@ -240,6 +240,7 @@ ModuleExport void UnregisterDOTImage(voi
+ (void) UnregisterMagickInfo("GV");
+ (void) UnregisterMagickInfo("DOT");
+ #if defined(MAGICKCORE_GVC_DELEGATE)
++ if (graphic_context != NULL)
+ gvFreeContext(graphic_context);
+ #endif
+ }