summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-07-29 18:29:58 -0400
committerMark H Weaver <mhw@netris.org>2016-07-29 18:29:58 -0400
commit359aba76b655813895e7ed9290110e3750914d8b (patch)
treea9f3493e76277cfc906e44c0fb1df07300f73260 /gnu/packages/patches
parent0bab3af0786ffd4caec05a29d7281ac5e5c18b6b (diff)
parent9bdf56dc1349d1759fc670ff8715de25de0f0a9c (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gd-fix-gd2-read-test.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/gd-fix-gd2-read-test.patch b/gnu/packages/patches/gd-fix-gd2-read-test.patch
new file mode 100644
index 0000000000..65f39e4426
--- /dev/null
+++ b/gnu/packages/patches/gd-fix-gd2-read-test.patch
@@ -0,0 +1,14 @@
+Fix a 'maybe-uninitialized' warning (turned error)
+which occurs on non-Intel platforms.
+
+--- libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-21 01:21:16.000000000 -0400
++++ libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-29 15:52:03.806405312 -0400
+@@ -5,7 +5,7 @@
+
+ int main(int argc, char *argv[])
+ {
+- int error, i = 0;
++ int error = 0, i = 0;
+ gdImagePtr im, exp;
+ FILE *fp;
+ char *path[] = {