summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-07-31 23:27:03 -0400
committerMark H Weaver <mhw@netris.org>2016-07-31 23:27:03 -0400
commit3d337bbc3916b95c0197ebbb890875f0439eec53 (patch)
treeffd4098c3ec8e7af659f2e70448e45180b2a7cfb /gnu/packages/patches
parent932b2ea2064ec8ab8e81b959bd92f6138974fd39 (diff)
parent4e8efc15fb9082fb80726a2a37c4e6ebb13552fa (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/beets-image-test-failure.patch46
-rw-r--r--gnu/packages/patches/tuxpaint-stamps-path.patch24
2 files changed, 24 insertions, 46 deletions
diff --git a/gnu/packages/patches/beets-image-test-failure.patch b/gnu/packages/patches/beets-image-test-failure.patch
deleted file mode 100644
index 360d7d3ed4..0000000000
--- a/gnu/packages/patches/beets-image-test-failure.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Fix test failure due to missing image library backend.
-
-Cherry-picked from upstream:
-https://github.com/beetbox/beets/commit/07c95a1bf16bf86c640436208dda828cc7df0181
-
-From 07c95a1bf16bf86c640436208dda828cc7df0181 Mon Sep 17 00:00:00 2001
-From: Adrian Sampson <adrian@radbox.org>
-Date: Thu, 2 Jun 2016 11:39:05 -0700
-Subject: [PATCH] Require an imaging backend for fuzzy ratio tests
-
-These fail outright if we don't have a way to get image sizes (e.g.,
-ImageMagick).
----
- test/test_art.py | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/test/test_art.py b/test/test_art.py
-index 02d26f4..1b12b76 100644
---- a/test/test_art.py
-+++ b/test/test_art.py
-@@ -561,21 +561,25 @@ def test_respect_enforce_ratio_no(self):
- self._assertImageIsValidArt(self.IMG_500x490, True)
-
- def test_respect_enforce_ratio_px_above(self):
-+ self._require_backend()
- self.plugin.enforce_ratio = True
- self.plugin.margin_px = 5
- self._assertImageIsValidArt(self.IMG_500x490, False)
-
- def test_respect_enforce_ratio_px_below(self):
-+ self._require_backend()
- self.plugin.enforce_ratio = True
- self.plugin.margin_px = 15
- self._assertImageIsValidArt(self.IMG_500x490, True)
-
- def test_respect_enforce_ratio_percent_above(self):
-+ self._require_backend()
- self.plugin.enforce_ratio = True
- self.plugin.margin_percent = (500 - 490) / 500 * 0.5
- self._assertImageIsValidArt(self.IMG_500x490, False)
-
- def test_respect_enforce_ratio_percent_below(self):
-+ self._require_backend()
- self.plugin.enforce_ratio = True
- self.plugin.margin_percent = (500 - 490) / 500 * 1.5
- self._assertImageIsValidArt(self.IMG_500x490, True)
diff --git a/gnu/packages/patches/tuxpaint-stamps-path.patch b/gnu/packages/patches/tuxpaint-stamps-path.patch
new file mode 100644
index 0000000000..599a33c458
--- /dev/null
+++ b/gnu/packages/patches/tuxpaint-stamps-path.patch
@@ -0,0 +1,24 @@
+--- tuxpaint-0.9.22/src/tuxpaint.c
++++ tuxpaint-0.9.22/src/tuxpaint.c
+@@ -7474,11 +7474,21 @@
+ static void load_stamps(SDL_Surface * screen)
+ {
+ char *homedirdir = get_fname("stamps", DIR_DATA);
++ char *stamps_path = getenv("TUXPAINT_STAMPS_PATH");
+
+ default_stamp_size = compute_default_scale_factor(1.0);
+
+ load_stamp_dir(screen, homedirdir);
+ load_stamp_dir(screen, DATA_PREFIX "stamps");
++ /* Load any stamps in TUXPAINT_STAMPS_PATH */
++ if (stamps_path) {
++ char *token;
++ token = strtok(stamps_path, ":");
++ while (token != NULL) {
++ load_stamp_dir(screen, token);
++ token = strtok(NULL, ":");
++ }
++ }
+ #ifdef __APPLE__
+ load_stamp_dir(screen, "/Library/Application Support/TuxPaint/stamps");
+ #endif