summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-06-27 23:57:45 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-06-28 17:26:49 +0200
commit013ce67b193326f4dfbdddb3c6445d542476bd93 (patch)
tree119e910de17340d748f84f5e997abf675df51ffd /gnu/packages/patches
parent88a0b7b05127b1e1ca6672ead75925249f9fa114 (diff)
gnutls: fix the test-suite for 32 bits systems.
* gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch: New file. * gnu-system.am: Add it here... * gnu/packages/gnutls.scm (gnutls): ... and use it here. Thanks to Nikos Mavrogiannopoulos for providing this patch: http://permalink.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/6778
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch b/gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch
new file mode 100644
index 0000000000..07d633149e
--- /dev/null
+++ b/gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch
@@ -0,0 +1,36 @@
+From b12040aeab5fbaf02677571db1d8bf1995bd5ee0 Mon Sep 17 00:00:00 2001
+From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
+Date: Sun, 2 Jun 2013 12:10:06 +0200
+Subject: [PATCH] Avoid comparing the expiration date to prevent false positive
+error in 32-bit systems.
+
+---
+ tests/cert-tests/pem-decoding | 6 ++++--
+ 1 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/tests/cert-tests/pem-decoding b/tests/cert-tests/pem-decoding
+index fe769ec..f8c6372 100755
+--- tests/cert-tests/pem-decoding
++++ tests/cert-tests/pem-decoding
+@@ -61,7 +61,9 @@ if test "$rc" != "0"; then
+ exit $rc
+ fi
+
+-diff $srcdir/complex-cert.pem tmp-pem.pem
++cat $srcdir/complex-cert.pem |grep -v "Not After:" >tmp1
++cat $srcdir/tmp-pem.pem |grep -v "Not After:" >tmp2
++diff tmp1 tmp2
+ rc=$?
+
+ if test "$rc" != "0"; then
+@@ -69,6 +71,6 @@ if test "$rc" != "0"; then
+ exit $rc
+ fi
+
+-rm -f tmp-pem.pem
++rm -f tmp-pem.pem tmp1 tmp2
+
+ exit 0
+--
+1.7.1
+