summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-07-07 00:55:41 -0500
committerEric Bavier <bavier@member.fsf.org>2016-08-17 22:08:32 -0500
commit22df70010aed4254e8bcf8cd8efe47cfcf87a3bd (patch)
treec51e0ff05523688a6b5e25b0ef44c00354ce6c8f /gnu/packages/patches
parentd1cada0450fca54260fd20ab49d0586d147cbeb3 (diff)
gnu: Add NetSurf.
* gnu/packages/web.scm (netsurf): New variable. * gnu/packages/patches/netsurf-about.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/netsurf-about.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/netsurf-about.patch b/gnu/packages/patches/netsurf-about.patch
new file mode 100644
index 0000000000..1fb8eae824
--- /dev/null
+++ b/gnu/packages/patches/netsurf-about.patch
@@ -0,0 +1,26 @@
+--- netsurf-all-3.5/netsurf/gtk/about.c
++++ netsurf-all-3.5/netsurf/gtk/about.c
+@@ -79,11 +79,11 @@
+ switch (response_id) {
+
+ case ABOUT_RESPONSE_ID_LICENCE:
+- about_open("about:credits");
++ about_open("about:licence");
+ break;
+
+ case ABOUT_RESPONSE_ID_CREDITS:
+- about_open("about:licence");
++ about_open("about:credits");
+ break;
+ }
+
+--- netsurf-all-3.5/netsurf/desktop/version.c
++++ netsurf-all-3.5/netsurf/desktop/version.c
+@@ -20,6 +20,6 @@
+
+ #include "desktop/version.h"
+
+-const char * const netsurf_version = "3.5 (6th April 1016)";
++const char * const netsurf_version = "3.5 (6th April 2016)";
+ const int netsurf_version_major = 3;
+ const int netsurf_version_minor = 5;