summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-01-04 16:38:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-04 18:06:44 +0100
commit68f90673242777feea9537d6e506d97ea8506c45 (patch)
tree0bb9d99576ff2780e53dd10e72797451abda9613 /gnu/packages/patches
parent6548e53fcbb125062719a9324ff65f6994e7b847 (diff)
gnu: inkscape: Update to 0.92.0.
* gnu/packages/patches/inkscape-drop-wait-for-targets.patch: Remove it. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/inkscape.scm (inkscape): Update to 0.92.0. [build-system]: Use "cmake-build-system". [native-inputs]: Add glib:bin. [arguments]: Remove obsolete arguments; disable tests.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/inkscape-drop-wait-for-targets.patch68
1 files changed, 0 insertions, 68 deletions
diff --git a/gnu/packages/patches/inkscape-drop-wait-for-targets.patch b/gnu/packages/patches/inkscape-drop-wait-for-targets.patch
deleted file mode 100644
index 3dbe6641e2..0000000000
--- a/gnu/packages/patches/inkscape-drop-wait-for-targets.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-Copied from Fedora.
-
-http://pkgs.fedoraproject.org/cgit/rpms/inkscape.git/plain/inkscape-0.91-drop-wait-for-targets.patch?id=eb5340800b563d6b05aa5f11a2f24f2cc0d8c80e
-
-=== modified file 'src/ui/clipboard.cpp'
---- src/ui/clipboard.cpp 2016-04-02 15:15:43 +0000
-+++ src/ui/clipboard.cpp 2016-04-07 16:30:32 +0000
-@@ -146,8 +146,6 @@
- void _setClipboardColor(guint32);
- void _userWarn(SPDesktop *, char const *);
-
-- void _inkscape_wait_for_targets(std::list<Glib::ustring> &);
--
- // private properites
- SPDocument *_clipboardSPDoc; ///< Document that stores the clipboard until someone requests it
- Inkscape::XML::Node *_defs; ///< Reference to the clipboard document's defs node
-@@ -1302,9 +1300,7 @@
- */
- Glib::ustring ClipboardManagerImpl::_getBestTarget()
- {
-- // GTKmm's wait_for_targets() is broken, see the comment in _inkscape_wait_for_targets()
-- std::list<Glib::ustring> targets; // = _clipboard->wait_for_targets();
-- _inkscape_wait_for_targets(targets);
-+ std::list<Glib::ustring> targets = _clipboard->wait_for_targets();
-
- // clipboard target debugging snippet
- /*
-@@ -1456,39 +1452,6 @@
- desktop->messageStack()->flash(Inkscape::WARNING_MESSAGE, msg);
- }
-
--
--// GTKMM's clipboard::wait_for_targets is buggy and might return bogus, see
--//
--// https://bugs.launchpad.net/inkscape/+bug/296778
--// http://mail.gnome.org/archives/gtk-devel-list/2009-June/msg00062.html
--//
--// for details. Until this has been fixed upstream we will use our own implementation
--// of this method, as copied from /gtkmm-2.16.0/gtk/gtkmm/clipboard.cc.
--void ClipboardManagerImpl::_inkscape_wait_for_targets(std::list<Glib::ustring> &listTargets)
--{
-- //Get a newly-allocated array of atoms:
-- GdkAtom* targets = NULL;
-- gint n_targets = 0;
-- gboolean test = gtk_clipboard_wait_for_targets( gtk_clipboard_get(GDK_SELECTION_CLIPBOARD), &targets, &n_targets );
-- if (!test || (targets == NULL)) {
-- return;
-- }
--
-- //Add the targets to the C++ container:
-- for (int i = 0; i < n_targets; i++)
-- {
-- //Convert the atom to a string:
-- gchar* const atom_name = gdk_atom_name(targets[i]);
--
-- Glib::ustring target;
-- if (atom_name) {
-- target = Glib::ScopedPtr<char>(atom_name).get(); //This frees the gchar*.
-- }
--
-- listTargets.push_back(target);
-- }
--}
--
- /* #######################################
- ClipboardManager class
- ####################################### */
-