summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-06-07 22:03:26 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-06-21 21:46:45 +1000
commit9270298f7521eb5ca654186c44a8b203f4584d62 (patch)
treec01389ae39704188a8bd982aa920b631621d2153 /gnu/packages/patches
parentb08134907d98057d9cf2e1bfbd6afb067af15045 (diff)
gnu: Add ruby-puma.
gnu/packages/ruby.scm (ruby-puma): New variable. gnu/packages/patches/ruby-puma-ignore-broken-test.patch: New file. gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ruby-puma-ignore-broken-test.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/ruby-puma-ignore-broken-test.patch b/gnu/packages/patches/ruby-puma-ignore-broken-test.patch
new file mode 100644
index 0000000000..fb653dc0ee
--- /dev/null
+++ b/gnu/packages/patches/ruby-puma-ignore-broken-test.patch
@@ -0,0 +1,13 @@
+diff --git a/test/test_integration.rb b/test/test_integration.rb
+index d9b189c..6e21180 100644
+--- a/test/test_integration.rb
++++ b/test/test_integration.rb
+@@ -115,7 +115,7 @@ class TestIntegration < Test::Unit::TestCase
+ assert_kind_of Thread, t.join(1), "server didn't stop"
+ end
+
+- def test_phased_restart_via_pumactl
++ def no_test_phased_restart_via_pumactl
+ if Puma.jruby? || Puma.windows?
+ assert true
+ return