summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2016-04-12 15:49:17 +0200
committerLudovic Courtès <ludo@gnu.org>2016-12-07 10:23:17 +0100
commitae12d586275cdd96db23fb01bf840b2055b5b979 (patch)
tree8e350dc92ad2384f86c2fe78599ef3792d714917 /gnu/packages/patches
parentd230cf61f6adecf46a9008071fd0300166e542a6 (diff)
gnu: readline: support mingw.
* gnu/packages/patches/readline-7.0-mingw.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/readline.scm (readline): Support MinGW.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/readline-7.0-mingw.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/readline-7.0-mingw.patch b/gnu/packages/patches/readline-7.0-mingw.patch
new file mode 100644
index 0000000000..1dc491d556
--- /dev/null
+++ b/gnu/packages/patches/readline-7.0-mingw.patch
@@ -0,0 +1,28 @@
+Configure checks for chown; add missing shields in code.
+
+Upstream status: not yet presented upstream.
+
+--- readline-7.0/histfile.c.orig 2016-12-06 20:04:10.058901731 +0100
++++ readline-7.0/histfile.c 2016-12-06 20:05:09.220083801 +0100
+@@ -610,8 +610,10 @@
+ user is running this, it's a no-op. If the shell is running after sudo
+ with a shared history file, we don't want to leave the history file
+ owned by root. */
++#if HAVE_CHOWN
+ if (rv == 0 && exists)
+ r = chown (filename, finfo.st_uid, finfo.st_gid);
++#endif
+
+ xfree (filename);
+ FREE (tempname);
+@@ -757,8 +759,10 @@
+ user is running this, it's a no-op. If the shell is running after sudo
+ with a shared history file, we don't want to leave the history file
+ owned by root. */
++#if HAVE_CHOWN
+ if (rv == 0 && exists)
+ mode = chown (histname, finfo.st_uid, finfo.st_gid);
++#endif
+
+ FREE (histname);
+ FREE (tempname);