summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-10-23 23:11:38 -0400
committerMark H Weaver <mhw@netris.org>2015-10-23 23:11:38 -0400
commitd3365d486636b36c95ce17deefbc169f3d4f0e9a (patch)
tree9dfad056c14d203d8f6aab1f7310a3e4a3484e00 /gnu/packages/patches
parent6e4512c470c7196ae19f8166c7ec2d176f87d7af (diff)
parentca9745e484474f27d5773059a063c0d8e70f7e1d (diff)
Merge branch 'master' into dbus-update
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/evilwm-lost-focus-bug.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/evilwm-lost-focus-bug.patch b/gnu/packages/patches/evilwm-lost-focus-bug.patch
new file mode 100644
index 0000000000..af24af8fe9
--- /dev/null
+++ b/gnu/packages/patches/evilwm-lost-focus-bug.patch
@@ -0,0 +1,18 @@
+evilwm may sometimes lose focus after closing a window. This means that
+evilwm stops responding to keyboard shortcuts, and if no other window is open
+which the mouse can be moved over to regain focus evilwm becomes unusable and
+has to be restarted.
+
+Patch derived from discussion at
+https://wiki.archlinux.org/index.php/Evilwm#Lost_focus_bug_fix
+
+--- evilwm-1.1.1/client.c
++++ evilwm-1.1.1/client.c
+@@ -172,6 +172,7 @@
+ * _NET_WM_STATE) */
+ if (c->remove) {
+ LOG_DEBUG("setting WithdrawnState\n");
++ XSetInputFocus(dpy, PointerRoot, RevertToPointerRoot, CurrentTime);
+ set_wm_state(c, WithdrawnState);
+ ewmh_withdraw_client(c);
+ } else {