summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-01-25 20:42:49 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-25 21:52:08 +0100
commitdf84950e44050ae98d7e77905ceda381e43a4127 (patch)
tree37810f9028ff49f94701c0520c712e2ee48a05d2 /gnu/packages/patches
parent12a5199a27fc53a4c78f2b13756e2ba9fec195a6 (diff)
gnu: Add libapr.
* gnu/packages/libapr.scm: New file. * gnu/packages/patches/libapr-skip-getservbyname-test.patch: New file * Makefile.am: Add them
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/libapr-skip-getservbyname-test.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/libapr-skip-getservbyname-test.patch b/gnu/packages/patches/libapr-skip-getservbyname-test.patch
new file mode 100644
index 0000000000..e12a8eb56c
--- /dev/null
+++ b/gnu/packages/patches/libapr-skip-getservbyname-test.patch
@@ -0,0 +1,25 @@
+--- test/testsock.c 2013-01-24 06:57:21.000000000 +0100
++++ test/testsock.c 2013-01-24 17:24:54.000000000 +0100
+@@ -90,16 +90,22 @@
+ rv = apr_sockaddr_info_get(&sa, NULL, APR_UNSPEC, 0, 0, p);
+ APR_ASSERT_SUCCESS(tc, "Problem generating sockaddr", rv);
+
++ /* /etc/services is not available while compiling, so apr_getservbyname
++ * will always return APR_ENOENT. */
++#if 0
+ rv = apr_getservbyname(sa, "ftp");
+ APR_ASSERT_SUCCESS(tc, "Problem getting ftp service", rv);
+ ABTS_INT_EQUAL(tc, 21, sa->port);
++#endif
+
+ rv = apr_getservbyname(sa, "complete_and_utter_rubbish");
+ APR_ASSERT_SUCCESS(tc, "Problem getting non-existent service", !rv);
+
++#if 0
+ rv = apr_getservbyname(sa, "telnet");
+ APR_ASSERT_SUCCESS(tc, "Problem getting telnet service", rv);
+ ABTS_INT_EQUAL(tc, 23, sa->port);
++#endif
+ }
+
+ static apr_socket_t *setup_socket(abts_case *tc)