summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEric Dvorsak <yenda1@gmail.com>2015-08-02 19:27:24 +0200
committerMark H Weaver <mhw@netris.org>2015-08-06 16:33:54 -0400
commitff6f33cf80d04717cad90177c934ae5b2dd6086c (patch)
tree1a2cceb462765d77dad2d234387ab8f23f476e5a /gnu/packages/patches
parent9f6509c655b766b0fb9dfab181a8533e698473b0 (diff)
gnu: python-2: Update to 2.7.10.
* gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch, gnu/packages/patches/python-libffi-mips-n32-fix.patch: Remove files. * gnu-system.am (dist_patch_DATA): Remove them. * gnu/packages/python.scm (python-2): Update to 2.7.10. Remove patches. Update comment showing test failures.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-libffi-mips-n32-fix.patch21
-rw-r--r--gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch15
2 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/patches/python-libffi-mips-n32-fix.patch b/gnu/packages/patches/python-libffi-mips-n32-fix.patch
deleted file mode 100644
index 393883779d..0000000000
--- a/gnu/packages/patches/python-libffi-mips-n32-fix.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Fix handling of uint32_t arguments on the MIPS N32 ABI.
-
-Patch by Mark H Weaver <mhw@netris.org>.
-
---- Modules/_ctypes/libffi/src/mips/ffi.c.orig 2013-03-16 07:19:39.000000000 -0400
-+++ Modules/_ctypes/libffi/src/mips/ffi.c 2013-10-22 01:11:03.111985247 -0400
-@@ -170,7 +170,14 @@
- break;
-
- case FFI_TYPE_UINT32:
-+#ifdef FFI_MIPS_N32
-+ /* The N32 ABI requires that 32-bit integers
-+ be sign-extended to 64-bits, regardless of
-+ whether they are signed or unsigned. */
-+ *(ffi_arg *)argp = *(SINT32 *)(* p_argv);
-+#else
- *(ffi_arg *)argp = *(UINT32 *)(* p_argv);
-+#endif
- break;
-
- /* This can only happen with 64bit slots. */
diff --git a/gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch b/gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch
deleted file mode 100644
index f121e8852a..0000000000
--- a/gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-From resolution of upstream python issue #20901: http://bugs.python.org/issue20901
-
-diff --git a/Lib/sqlite3/test/hooks.py b/Lib/sqlite3/test/hooks.py
---- Lib/sqlite3/test/hooks.py
-+++ Lib/sqlite3/test/hooks.py
-@@ -162,7 +162,7 @@ class ProgressTests(unittest.TestCase):
- create table bar (a, b)
- """)
- second_count = len(progress_calls)
-- self.assertTrue(first_count > second_count)
-+ self.assertGreaterEqual(first_count, second_count)
-
- def CheckCancelOperation(self):
- """
-