summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-08 14:26:42 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-08 15:23:39 +0200
commit849a1399ca46497ad6acc5b11903f345502c02de (patch)
tree5baa10b0f646201e061fad9a58a8456065760529 /gnu/packages/patches
parent9953685c0985c6cc4481db3e351f1cc1dbf81e8b (diff)
gnu: doxygen: Work around GCC ICE on armhf-linux.
Reported by Mark H Weaver <mhw@netris.org> at <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=31708#10>. * gnu/packages/patches/doxygen-gcc-ice.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/documentation.scm (doxygen)[inputs]: Add "gcc-ice-patch" on armhf-* only. [arguments]: Add 'apply-gcc-patch' phase on armhf-* only.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/doxygen-gcc-ice.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/doxygen-gcc-ice.patch b/gnu/packages/patches/doxygen-gcc-ice.patch
new file mode 100644
index 0000000000..fbfedcb7ab
--- /dev/null
+++ b/gnu/packages/patches/doxygen-gcc-ice.patch
@@ -0,0 +1,25 @@
+Work around this GCC ICE: <https://bugs.gnu.org/31708>. It shows up
+only when doing native compiles on armhf-linux.
+
+Yes it's a terrible patch, but it does the job.
+
+--- doxygen-1.8.13/qtools/qutfcodec.cpp 1970-01-01 01:00:00.000000000 +0100
++++ doxygen-1.8.13/qtools/qutfcodec.cpp 2018-06-08 14:14:29.614009929 +0200
+@@ -189,7 +189,7 @@ int QUtf16Codec::heuristicContentMatch(c
+ }
+
+
+-
++volatile const void *bomPointer = &QChar::byteOrderMark;
+
+ class QUtf16Encoder : public QTextEncoder {
+ bool headerdone;
+@@ -209,7 +209,7 @@ public:
+ headerdone = TRUE;
+ len_in_out = (1+uc.length())*(int)sizeof(QChar);
+ QCString d(len_in_out);
+- memcpy(d.rawData(),&QChar::byteOrderMark,sizeof(QChar));
++ memcpy(d.rawData(),(void *)bomPointer,sizeof(QChar));
+ memcpy(d.rawData()+sizeof(QChar),uc.unicode(),uc.length()*sizeof(QChar));
+ return d;
+ }