summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-07-29 22:44:37 +1000
committerBen Woodcroft <donttrustben@gmail.com>2018-07-29 22:53:10 +1000
commit9e0c135c39b5f1fa2c5c9cd4a1e50ccee75cc31e (patch)
tree5fa0a3d6f41d8354d017cbec60d00d1836c1a70c /gnu/packages/patches
parent19601e895b816afc033a155a9309037ec21fd3ed (diff)
gnu: python-dendropy: Update to 4.4.0.
* gnu/packages/bioinformatics.scm (python-dendropy, python2-dendropy): Update to 4.4.0. [source]: Use GitHub URI. Remove patch. [properties]: Remove field. (python2-dendropy)[arguments]: Run tests with setup.py. [native-inputs]: Remove 'python2-nose. * gnu/packages/patches/python-dendropy-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Delete it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-dendropy-fix-tests.patch41
1 files changed, 0 insertions, 41 deletions
diff --git a/gnu/packages/patches/python-dendropy-fix-tests.patch b/gnu/packages/patches/python-dendropy-fix-tests.patch
deleted file mode 100644
index 30ab618ff1..0000000000
--- a/gnu/packages/patches/python-dendropy-fix-tests.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-This patch fixes two test failures. It was downloaded from:
-https://github.com/jeetsukumaran/DendroPy/commit/93f984bba7a6c588a28ca87f4e557ce283809453
-
-From 93f984bba7a6c588a28ca87f4e557ce283809453 Mon Sep 17 00:00:00 2001
-From: jeetsukumaran <jeetsukumaran@gmail.com>
-Date: Tue, 21 Feb 2017 16:41:01 -0500
-Subject: [PATCH] Update to Python 3 container and iteration semantics
-
----
- dendropy/dataio/newickreader.py | 3 ++-
- dendropy/datamodel/treemodel.py | 3 +++
- 2 files changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/dendropy/dataio/newickreader.py b/dendropy/dataio/newickreader.py
-index 6dcf3c5..f978729 100644
---- a/dendropy/dataio/newickreader.py
-+++ b/dendropy/dataio/newickreader.py
-@@ -303,7 +303,8 @@ def tree_iter(self,
- taxon_symbol_map_fn=taxon_symbol_mapper.require_taxon_for_symbol)
- yield tree
- if tree is None:
-- raise StopIteration
-+ # raise StopIteration
-+ return
-
- def _read(self,
- stream,
-diff --git a/dendropy/datamodel/treemodel.py b/dendropy/datamodel/treemodel.py
-index 0ecfe31..73146f0 100644
---- a/dendropy/datamodel/treemodel.py
-+++ b/dendropy/datamodel/treemodel.py
-@@ -772,6 +772,9 @@ def __hash__(self):
- def __eq__(self, other):
- return self is other
-
-+ def __lt__(self, other):
-+ return id(self) < id(other)
-+
- ###########################################################################
- ### Basic Structure
-