summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-01 11:49:17 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-01 12:06:00 +0200
commit0cf2b6f2dbcd299f7a4b7a563cf34ae5de154b15 (patch)
tree0b653bb411222fda1d159cb05bee722ff8bac9cc /gnu/packages/patches
parent8d564b8b81b98fec9aac2f5f2d3cb0d1f2ea1416 (diff)
parent717b6ba6aa9ac876b2c2df36096e4579b19ee06c (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/abcl-fix-build-xml.patch50
-rw-r--r--gnu/packages/patches/dealii-mpi-deprecations.patch28
-rw-r--r--gnu/packages/patches/mame-rapidjson-fix.patch37
3 files changed, 50 insertions, 65 deletions
diff --git a/gnu/packages/patches/abcl-fix-build-xml.patch b/gnu/packages/patches/abcl-fix-build-xml.patch
new file mode 100644
index 0000000000..dd315b4271
--- /dev/null
+++ b/gnu/packages/patches/abcl-fix-build-xml.patch
@@ -0,0 +1,50 @@
+ABCL's build calls the hostname command, and needs the internet to download
+JUnit. Neither of these are really required, though, so we can patch them out
+to make it build.
+
+We also remove the Implemetation-Build property that ends up in the manifest
+file, because it stores information about the time of the build, which makes
+it non-deterministic.
+
+--- a/build.xml
++++ b/build.xml
+@@ -327,7 +327,7 @@ from ${abcl.home.dir}
+ <property name="abcl.build.path"
+ value="${build.classes.dir}/org/armedbear/lisp/build"/>
+ <target name="abcl.stamp"
+- depends="abcl.compile,abcl.stamp.version,abcl.stamp.hostname">
++ depends="abcl.compile,abcl.stamp.version">
+ <mkdir dir="${abcl.build.path}/.."/>
+ <loadfile property="abcl.version"
+ srcFile="${abcl.version.path}"/>
+@@ -455,11 +455,6 @@ from ${abcl.home.dir}
+ value="${abcl.version}-${abcl.version.src}"/>
+ </target>
+
+- <target name="abcl.stamp.hostname" if="unix">
+- <exec executable="hostname" outputproperty="abcl.hostname"/>
+- <echo>abcl.hostname: ${abcl.hostname}</echo>
+- </target>
+-
+ <target name="abcl.system.uptodate">
+ <condition property="abcl.system.needs-update.p">
+ <and>
+@@ -500,8 +495,6 @@ from ${abcl.home.dir}
+ value="ABCL"/>
+ <attribute name="Implementation-Version"
+ value="${abcl.implementation.version}"/>
+- <attribute name="Implementation-Build"
+- value="${build}"/>
+ </section>
+ </manifest>
+ <metainf dir="${src.dir}/META-INF">
+@@ -1019,8 +1012,7 @@ ${basedir}/../cl-bench
+ </unzip>
+ </target>
+
+- <target name="abcl.test.compile"
+- depends="abcl.test.pre-compile">
++ <target name="abcl.test.compile" >
+ <mkdir dir="${abcl.test.classes.dir}"/>
+ <javac destdir="${abcl.test.classes.dir}"
+ classpathref="abcl.test.compile.classpath"
diff --git a/gnu/packages/patches/dealii-mpi-deprecations.patch b/gnu/packages/patches/dealii-mpi-deprecations.patch
deleted file mode 100644
index 816d54140a..0000000000
--- a/gnu/packages/patches/dealii-mpi-deprecations.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 40538ad31a71495649d174b0f7be5f7135d0a905 Mon Sep 17 00:00:00 2001
-From: David Wells <drwells@email.unc.edu>
-Date: Sat, 2 Feb 2019 10:00:38 -0500
-Subject: [PATCH] Avoid calling a deprecated MPI function.
-
-This was deprecated a long time ago (1996) and is not present in the
-latest version of openMPI (4.0): see
-
-https://www.open-mpi.org/faq/?category=mpi-removed
-
-Credit goes to Pratik Nayak for finding this issue.
----
- source/base/mpi.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/source/base/mpi.cc b/source/base/mpi.cc
-index bd1f7f9846a..b8cd45e7c26 100644
---- a/source/base/mpi.cc
-+++ b/source/base/mpi.cc
-@@ -448,7 +448,7 @@ namespace Utilities
- MPI_Aint displacements[] = {0, offsetof(MinMaxAvg, min_index)};
- MPI_Datatype types[] = {MPI_DOUBLE, MPI_INT};
-
-- ierr = MPI_Type_struct(2, lengths, displacements, types, &type);
-+ ierr = MPI_Type_create_struct(2, lengths, displacements, types, &type);
- AssertThrowMPI(ierr);
-
- ierr = MPI_Type_commit(&type);
diff --git a/gnu/packages/patches/mame-rapidjson-fix.patch b/gnu/packages/patches/mame-rapidjson-fix.patch
deleted file mode 100644
index 70cf8458ea..0000000000
--- a/gnu/packages/patches/mame-rapidjson-fix.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 0b5b13cf1e28550b49c387dec93f9801f029e313 Mon Sep 17 00:00:00 2001
-From: Julian Sikorski <belegdol+github@gmail.com>
-Date: Mon, 5 Aug 2019 21:16:54 +0200
-Subject: [PATCH] Fix building using system rapidjson
-
----
- scripts/target/mame/arcade.lua | 1 +
- src/mame/video/midtunit.cpp | 4 ++--
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/scripts/target/mame/arcade.lua b/scripts/target/mame/arcade.lua
-index 964daa3572f..ef30ae3c2c2 100644
---- a/scripts/target/mame/arcade.lua
-+++ b/scripts/target/mame/arcade.lua
-@@ -930,6 +930,7 @@ function createMAMEProjects(_target, _subtarget, _name)
- ext_includedir("flac"),
- ext_includedir("glm"),
- ext_includedir("jpeg"),
-+ ext_includedir("rapidjson"),
- }
-
- end
-diff --git a/src/mame/video/midtunit.cpp b/src/mame/video/midtunit.cpp
-index b4cb98abacf..b307f3f722b 100644
---- a/src/mame/video/midtunit.cpp
-+++ b/src/mame/video/midtunit.cpp
-@@ -20,8 +20,8 @@
- #include "emuopts.h" // Used by PNG logging
- #include "png.h" // Used by PNG logging
-
--#include "rapidjson/include/rapidjson/prettywriter.h" // Used by JSON logging
--#include "rapidjson/include/rapidjson/stringbuffer.h" // Used by JSON logging
-+#include <rapidjson/prettywriter.h> // Used by JSON logging
-+#include <rapidjson/stringbuffer.h> // Used by JSON logging
-
- DEFINE_DEVICE_TYPE(MIDTUNIT_VIDEO, midtunit_video_device, "tunitvid", "Midway T-Unit Video")
- DEFINE_DEVICE_TYPE(MIDWUNIT_VIDEO, midwunit_video_device, "wunitvid", "Midway W-Unit Video")