summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-14 20:52:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-15 17:19:27 +0200
commit1007640a63de6749a93e94a2751f66af56b01d07 (patch)
tree2bb80ee12174e58cfffa7398d74fc9bc7e73dbae /gnu/packages/patches
parent8fcba3be282b4df60eec99338e5afee061d87242 (diff)
gnu: ruby-concurrent: Update to 1.1.5.
* gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch, gnu/packages/patches/ruby-concurrent-test-arm.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/ruby.scm (ruby-concurrent): Update to 1.1.5. [source](patches): Remove. [arguments]: Set #:test-target to "ci". Remove obsolete phases. Remove dependencies on 'rake_compiler_dock' and concurrent_ruby.jar.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch16
-rw-r--r--gnu/packages/patches/ruby-concurrent-test-arm.patch36
2 files changed, 0 insertions, 52 deletions
diff --git a/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch b/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
deleted file mode 100644
index 4e801c3225..0000000000
--- a/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-This test appears to fail in GNU Guix and elsewhere. It has been reported
-upstream at https://github.com/puma/puma/issues/995
-
-diff --git a/spec/concurrent/channel_spec.rb b/spec/concurrent/channel_spec.rb
-index d70fba8..4f29a8b 100644
---- a/spec/concurrent/channel_spec.rb
-+++ b/spec/concurrent/channel_spec.rb
-@@ -598,7 +598,7 @@ module Concurrent
- }.to raise_error(ArgumentError)
- end
-
-- it 'loops until the block returns false' do
-+ xit 'loops until the block returns false' do
- actual = 0
- expected = 3
- latch = Concurrent::CountDownLatch.new(expected)
diff --git a/gnu/packages/patches/ruby-concurrent-test-arm.patch b/gnu/packages/patches/ruby-concurrent-test-arm.patch
deleted file mode 100644
index 06d5657814..0000000000
--- a/gnu/packages/patches/ruby-concurrent-test-arm.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Work around two test suite failures on ARM:
-
- https://github.com/ruby-concurrency/concurrent-ruby/issues/547
-
-The regexps here assume addresses like "0x1234" but on ARM (32-bit)
-we get something like "0x-7db1e810" (notice the dash).
-
-diff --git a/spec/concurrent/edge/promises_spec.rb b/spec/concurrent/edge/promises_spec.rb
-index 727210f..149f7cd 100644
---- a/spec/concurrent/edge/promises_spec.rb
-+++ b/spec/concurrent/edge/promises_spec.rb
-@@ -371,9 +371,9 @@ describe 'Concurrent::Promises' do
- four = three.delay.then(&:succ)
-
- # meaningful to_s and inspect defined for Future and Promise
-- expect(head.to_s).to match /<#Concurrent::Promises::Future:0x[\da-f]+ pending>/
-+ expect(head.to_s).to match /<#Concurrent::Promises::Future:0x-?[\da-f]+ pending>/
- expect(head.inspect).to(
-- match(/<#Concurrent::Promises::Future:0x[\da-f]+ pending>/))
-+ match(/<#Concurrent::Promises::Future:0x-?[\da-f]+ pending>/))
-
- # evaluates only up to three, four is left unevaluated
- expect(three.value!).to eq 3
-diff --git a/spec/concurrent/map_spec.rb b/spec/concurrent/map_spec.rb
-index c4050be..0a9095d 100644
---- a/spec/concurrent/map_spec.rb
-+++ b/spec/concurrent/map_spec.rb
-@@ -794,7 +794,7 @@ module Concurrent
- end
-
- it '#inspect' do
-- regexp = /\A#<Concurrent::Map:0x[0-9a-f]+ entries=[0-9]+ default_proc=.*>\Z/i
-+ regexp = /\A#<Concurrent::Map:0x-?[0-9a-f]+ entries=[0-9]+ default_proc=.*>\Z/i
- expect(Concurrent::Map.new.inspect).to match(regexp)
- expect((Concurrent::Map.new {}).inspect).to match(regexp)
- map = Concurrent::Map.new