summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-09-16 22:20:23 -0500
committerEric Bavier <bavier@member.fsf.org>2019-09-24 21:15:24 -0500
commit4780db2c935110ea3254817ba0c519c229b9461e (patch)
treef070e8f3e3d12989feb7a0c4495449ac17f1c4f9 /gnu/packages/patches
parentc463c270dc0e1690d3c7cc19cd78583ce9bf9bd1 (diff)
gnu: idris: Update to 1.3.2.
* gnu/packages/haskell-xyz.scm (ghc-network-2.8, ghc-megaparsec-7): New variables. * gnu/packages/idris.scm (idris): Update to 1.3.2. [source]: Remove patch. [inputs]: Use ghc-network-2.8 and ghc-megaparsec-7. * gnu/packages/patches/idris-test-no-node.patch: Delete. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/idris-test-no-node.patch61
1 files changed, 0 insertions, 61 deletions
diff --git a/gnu/packages/patches/idris-test-no-node.patch b/gnu/packages/patches/idris-test-no-node.patch
deleted file mode 100644
index c04ad41a8e..0000000000
--- a/gnu/packages/patches/idris-test-no-node.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 6c52e1b902b869c25e2fe39cff6364143a04da61 Mon Sep 17 00:00:00 2001
-From: Niklas Larsson <niklas@mm.st>
-Date: Tue, 11 Dec 2018 19:56:22 +0100
-Subject: [PATCH] Only check for Node when required
-
----
- test/TestRun.hs | 34 ++++++++++++++++++++--------------
- 1 file changed, 20 insertions(+), 14 deletions(-)
-
-diff --git a/test/TestRun.hs b/test/TestRun.hs
-index c7db9fdcd..4809911f3 100644
---- a/test/TestRun.hs
-+++ b/test/TestRun.hs
-@@ -11,6 +11,7 @@ import Data.Proxy
- import Data.Typeable
- import Options.Applicative
- import System.Directory
-+import System.Environment
- import System.Exit
- import System.FilePath ((</>))
- import System.Info
-@@ -103,20 +104,25 @@ runTest path flags = do
- normalise (x : xs) = x : normalise xs
- normalise [] = []
-
-+checkNode :: IO ()
-+checkNode = do
-+ nodePath <- findExecutable "node"
-+ nodejsPath <- findExecutable "nodejs"
-+ let node = nodePath <|> nodejsPath
-+ case node of
-+ Nothing -> do
-+ putStrLn "For running the test suite against Node, node must be installed."
-+ exitFailure
-+ Just _ -> return ()
-+
- main :: IO ()
- main = do
-- nodePath <- findExecutable "node"
-- nodejsPath <- findExecutable "nodejs"
-- let node = nodePath <|> nodejsPath
-- case node of
-- Nothing -> do
-- putStrLn "For running the test suite against Node, node must be installed."
-- exitFailure
-- Just _ -> do
-- defaultMainWithIngredients ingredients $
-+ args <- getArgs
-+ when ("--node" `elem` args) checkNode
-+ defaultMainWithIngredients ingredients $
- askOption $ \(NodeOpt node) ->
-- let (codegen, flags) = if node then (JS, ["--codegen", "node"])
-- else (C , [])
-- in
-- mkGoldenTests (testFamiliesForCodegen codegen)
-- (flags ++ idrisFlags)
-+ let (codegen, flags) = if node then (JS, ["--codegen", "node"])
-+ else (C , [])
-+ in
-+ mkGoldenTests (testFamiliesForCodegen codegen) (flags ++ idrisFlags)
-+